PROBLEM

Das Widget Suche in ArcGIS Web AppBuilder gibt keine Ergebnisse der ArcGIS Server-Kartenservice-Layer zurück

Last Published: November 23, 2021

Beschreibung

Das Widget "Suche" in ArcGIS Web AppBuilder bietet den Benutzern die Möglichkeit, mithilfe eines Geokodierungsservice auf der Karte nach Positionen und Features zu suchen, um die durchsuchbaren Layer anzuzeigen. Wenn ein Ortsname oder Schlüsselwort in das Suchfeld eingegeben und auf einen der vorgeschlagenen Orte in der Dropdown-Liste geklickt wird, kann es vorkommen, dass die folgende Warnmeldung angezeigt wird:

Warnung: Keine Ergebnisse. Für "<vom Benutzer eingegebenes Schlüsselwort>" wurden keine Ergebnisse gefunden
Abbildung der Fehlermeldung.

Ursache

Dies ist ein bekanntes Problem. Das Widget "Suche" kann keine Features finden, wenn ein über eine SQL-Datenbanksicht erstellter Feature-Service für das Widget als Suchquelle festgelegt wurde. Weitere Informationen finden Sie unter BUG-000121482.

Lösung oder Problemumgehung

Ändern Sie zur Umgehung des Problems die maximale Anzahl der Vorschläge für das Widget "Suche" auf 0.

Hinweis Dieser Workaround funktioniert nur für ArcGIS Web AppBuilder in ArcGIS Online und nicht im Portal for ArcGIS 10.7. In Portal for ArcGIS ist dies nur in den Versionen 10.8 und später möglich.
  1. Klicken Sie bei der Konfiguration des Web AppBuilder im Widget Suche auf die Schaltfläche Dieses Widget konfigurieren Abbildung der Schaltfläche .
  2. Geben Sie im Fenster Konfigurieren Suche die Zahl 0 für Maximale Anzahl von Vorschlägen ein.
Konfigurieren des Widgets in 10.7.1. zeigt einen Fehler an
Konfigurieren des Widgets in 10.8.1 ist erfolgreich
  1. Legen Sie die gewünschten Einstellungen für die anderen Parameter fest, und klicken Sie auf OK, um die Konfiguration zu speichern.
  2. Klicken Sie auf Speichern und dann auf Starten, um den Web AppBuilder zu starten. Das Widget "Suche" zeigt nun bei der Eingabe der Schlüsselwörter anstelle von Vorschlägen nur die verfügbaren Ergebnisse an.
Die Ergebnisse des Widgets

Artikel-ID: 000023011

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln