PROBLEM

Erfasste Felder werden beim Anzeigen und Bearbeiten im Posteingang der mobilen ArcGIS Survey123-App leer angezeigt

Last Published: June 4, 2024

Beschreibung

Wenn in ArcGIS Survey123 Connect die Option "Posteingang" aktiviert ist, kann der Posteingang in der mobilen ArcGIS Survey123-Feld so eingestellt werden, dass die Anzeige und Bearbeitung möglich ist. Wenn jedoch die Optionen "Anzeigen von Surveys im Eingang zulassen" und "Bearbeiten von Surveys im Eingang zulassen" aktiviert sind, werden einige der zuvor erfassten Felder nicht zur Anzeige und Bearbeitung im Posteingang angezeigt. Wenn die Option "Bearbeiten" ausgewählt ist, können nur neue Datensätze zu den betroffenen Feldern hinzugefügt werden.

Ursache

  • Der Fragetyp "Wiederholungsfrage" wird in einem Survey verwendet. Felder mit dem Typ "Wiederholungsfrage" in einem Survey können grundsätzlich nicht über den Posteingang der mobilen App bearbeitet werden. Dadurch bleiben zuvor erfasste Felder innerhalb einer "Wiederholungsfrage" beim Anzeigen und Bearbeiten leer.
  • Die Spalte "relevant" wird in einer verschachtelten Wiederholung verwendet. Die Verwendung der Spalte "relevant" ist hilfreich, um die Sichtbarkeit von Fragen basierend auf der Antwort im vorherigen Feld zu steuern. Darüber hinaus wird während der Bearbeitung automatisch der vorherige Datensatz aus einem ausgeblendeten Feld gelöscht (wenn der entsprechende Ausdruck als "true" ausgewertet wird). Bei Verwendung in einer verschachtelten Wiederholung wird die erste erfasste Antwort des Feldes vom Typ "relevant" beim Anzeigen oder Bearbeiten über den Posteingang jedoch leer angezeigt. Die nachfolgenden Antworten in einer verschachtelten Wiederholung werden hingegen wie erwartet angezeigt, wie in den folgenden Abbildungen dargestellt.
Die erste erfasste Antwort, die im Posteingang leer angezeigt wird
Die zweite erfasste Antwort, die wie erwartet im Posteingang angezeigt wird
Die erfassten Survey-Antworten auf der Registerkarte "Daten" auf der ArcGIS Survey123-Website

Lösung oder Problemumgehung

Wählen Sie eine der folgenden Optionen aus, um sicherzustellen, dass alle zuvor erfassten Felder im Posteingang der mobilen ArcGIS Survey123-App angezeigt werden.

Angeben der Abfrage in der Spalte "bind::esri:parameters" für Wiederholungsfragen

Um das Standardverhalten eines Wiederholungsfeldes zu ändern, geben Sie den folgenden Ausdruck in der Spalte bind::esri:parameters an. Weitere Informationen finden Sie unter ArcGIS Survey123: Wiederholungen.

query allowUpdates=True

Ein Survey kann eine Wiederholung mit mehreren verschachtelten Wiederholungen enthalten. Der Ausdruck muss für alle Zeilen, in denen die Wiederholung beginnt, in der Spalte bind::esri:parameter festgelegt werden, und nicht nur für die übergeordnete Wiederholung. Wenn kein Ausdruck für die übergeordnete Wiederholung angegeben wird, tritt das Problem in allen Wiederholungsfragen auf, auch wenn der Ausdruck bereits für die verschachtelten Wiederholungsfragen angegeben wurde.

Angeben des Ausdrucks für die Sichtbarkeit von Fragen in der Spalte "body::esri:visible"

Um das Feld mit einer Sichtbarkeitseinstellung für Fragen im Posteingang der mobilen App anzuzeigen, geben Sie den folgenden Ausdruck in der Spalte body::esri:visible und nicht in der entsprechenden Spalte an. In diesem Beispiel wurde "selected(${environment},'indoor')" verwendet.

selected(${},'')
Der Ausdruck für die Sichtbarkeit von Fragen in der Spalte "body::esri:visible"

Wenn ein erfasstes Feld mit dieser Sichtbarkeitseinstellung bearbeitet wird und die bearbeitete Antwort nicht der Regel body::esri:visible entspricht, wird die Frage mit der zuvor erfassten Antwort in der Posteingangsansicht ausgeblendet. Der Datensatz bleibt jedoch weiterhin auf der Registerkarte "Daten" auf der ArcGIS Survey123-Website gespeichert. Dies kann zu inkohärenten Datensätzen führen, wenn die zuvor erfassten Daten für die ausgeblendete Frage nach einer Bearbeitung nicht mehr benötigt werden. Um die zuvor erfassten Daten bei Verwendung der Spalte "body::esri:visible" zu entfernen, löschen Sie manuell die erfasste Antwort auf die Frage mit der Sichtbarkeitseinstellung im Posteingang, bevor Sie den bearbeiteten Datensatz erneut senden.

Artikel-ID: 000032579

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln