PROBLEM

Auf der Anmeldeseite von Portal for ArcGIS sind nur Enterprise-Anmeldenamen zulässig, daher können Administratoren sich nicht anmelden

Last Published: May 5, 2021

Beschreibung

Wenn ein Enterprise-Anmeldename neu in Portal for ArcGIS eingerichtet wird, haben Administratoren möglicherweise keinen Zugriff auf die Portal-Startseite, da die Option für die Anmeldung mit einem integrierten Konto nicht verfügbar ist.

Ursache

Die Anmeldeoptionen des Enterprise-Anmeldenamens sind auf "Deren Anmeldedaten für Enterprise" festgelegt, wie Sie der folgenden Abbildung entnehmen können.

Die Abbildung der Benutzeroberfläche mit den Anmeldeoptionen

Diese Option deaktiviert die Anmeldenamen integrierter Benutzerkonten und lässt nur Enterprise-Anmeldenamen zu.

Die Abbildung mit der Benutzeroberfläche der Anmeldeseite.

Lösung oder Problemumgehung

Setzen Sie die Einstellungen über das ArcGIS-Portalverzeichnis zurück.

  1. Melden Sie sich über die folgende URL beim ArcGIS-Portalverzeichnis an:
https://<portal.domain.com>:7443/arcgis/sharing/rest/portals/self/update
  1. Klicken Sie auf die Organisations-ID: 0123456789ABCDEF
  2. Führen Sie einen Bildlauf bis zum unteren Rand aus, und klicken Sie unter Supported Operations auf Update.
  3. Führen Sie einen Bildlauf zur Optionsschaltfläche Can SignIn Using ArcGIS durch, und wählen Sie True aus.
  4. Klicken Sie auf Update Organization. In diesen Schritten werden Anmeldungen mit Benutzerkonten aktiviert.
Die Abbildung der Seite zum Aktualisieren der Einstellungen in ArcGIS Portal Directory

Aktivieren Sie für ArcGIS 10.8.1 und höher die Anmeldung mit ArcGIS über Postman erneut. Weitere Informationen finden Sie unter How To: Generieren und Verwenden eines ArcGIS Server-Tokens mit Postman. Fügen Sie gemäß der Dokumentation das folgende Schlüsselwertpaar aus Schritt 5 hinzu:

canSigninArcGIS: true

Die folgende Abbildung zeigt das Beispiel eines in Postman festgelegten Schlüsselwertpaares. Die Benutzeroberfläche für die Token-Erstellung mit dem Schlüssel

Artikel-ID: 000017882

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln