PROBLEM

Problem mit dem ArcGIS License Manager-Service beim Upgrade oder Deinstallieren und Neuinstallieren, wenn über ein ArcGIS Enterprise-Portal bereitgestellte Named-User-Lizenzen offline sind

Last Published: August 4, 2025

Beschreibung

Wenn über ein ArcGIS Enterprise-Portal bereitgestellte Named-User-Lizenzen offline sind, kann das Upgrade der ArcGIS License Manager-Software in einigen Fällen zu Problemen mit dem ArcGIS License Manager-Service führen.

Dieser Fall kann beim Upgrade von ArcGIS License Manager oder beim Deinstallieren und Installieren einer neueren Version von ArcGIS License Manager eintreten und dazu führen, dass der License Manager-Service fehlschlägt, wenn Named-User-Lizenzen, die über ein ArcGIS Enterprise-Portal bereitgestellt werden, offline sind.

Das Problem tritt nicht auf, wenn nur Concurrent-Use-Lizenzen ausgeliehen werden.

Ursache

Eine unvollständige Deinstallation des FLEXnet-Lizenzierungsservice kann dazu führen, dass der neu installierte Lizenzdienst nicht ordnungsgemäß gestartet wird.

Lösung oder Problemumgehung

Wenn die Deinstallation oder das Upgrade nicht gestartet wurde

  1. Beenden Sie den License Manager-Service.
  2. Öffnen Sie License Server Administrator.
  3. Drücken Sie im Dialogfeld Lizenzdienst starten/beenden des License Server Administrator auf Beenden.
  4. Schließen Sie den License Server Administrator.
  5. Fahren Sie mit dem In-Place-Upgrade fort, oder deinstallieren und installieren Sie die neuere ArcGIS License Manager-Instanz.

Wenn die Deinstallation oder das Upgrade durchgeführt wurde und ArcGIS License Manager nicht betriebsbereit ist

  1. Schließen Sie den License Server Administrator.
  2. Deinstallieren Sie ArcGIS License Manager.
  3. Installieren Sie die zuletzt installierte (vorherige) Version von ArcGIS License Manager neu.
  4. Vergewissern Sie sich, dass ArcGIS License Manager wieder betriebsbereit ist.
  5. Öffnen Sie ggf. den License Server Administrator.
  6. Drücken Sie im Dialogfeld Lizenzdienst starten/beenden des License Server Administrator auf Beenden.
  7. Schließen Sie den License Server Administrator.
  8. Fahren Sie mit dem In-Place-Upgrade fort, oder deinstallieren und installieren Sie die neuere ArcGIS License Manager-Instanz.

Bei Upgrades von ArcGIS License Manager 2024.0 auf höhere Versionen, z. B. auf ArcGIS License Manager 2024.1 oder höher, wurde das Problem behoben, und es ist keine Aktion erforderlich.

Beachten Sie, dass Upgrades von einer älteren Version auf ArcGIS License Manager 2024.0 von diesem Problem betroffen sind.

Artikel-ID: 000032434

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