PROBLEM

In ArcGIS Server Manager-Protokollen werden inkonsistente Abfrageergebnisse angezeigt

Last Published: June 26, 2024

Beschreibung

Beim Zugriff auf die Serverprotokolle in ArcGIS Server Manager werden in manchen Fällen inkonsistente Ergebnisse angezeigt. So werden beispielsweise bei bestimmten Filtern bei der ersten Abfrage die korrekten Ergebnisse angezeigt, während die nachfolgenden Abfragen falsche oder sonderbare Ergebnisse liefern.

Ursache

Die Protokolldateien in ArcGIS Server Manager sind beschädigt, da die Protokolle im ArcGIS-Server-Administratorverzeichnis ohne Inkonsistenzen angezeigt werden können.

Lösung oder Problemumgehung

Führen Sie die Bereinigungs-Operation durch. Im Rahmen der Bereinigungs-Operation wird die Bereinigung der Protokolle durch den Server erzwungen, wodurch Festplattenspeicher frei wird.

Warning:   
This operation is irreversible. Once invoked, this operation deletes all logs on every server machine on the site.
Note:
It is recommended to create a backup of the ArcGIS Server site configuration before proceeding with the following steps. Refer to ArcGIS Server: Making a backup of your site for instructions.
  1. Melden Sie sich beim ArcGIS-Server-Administratorverzeichnis als Administrator an. Die Standard-URL lautet:
https://<gisserver>.<domain.com>:6443/arcgis/admin
  1. Klicken Sie unter Resources auf logs.
  2. Klicken Sie unter Supported Operations auf clean.
  3. Wählen Sie auf der Seite Clean Logs das passende Format aus dem Dropdown-Menü Format aus, und klicken Sie auf Clean.
  4. Starten Sie den ArcGIS-Server-Service neu. Anweisungen hierzu finden Sie unter ArcGIS Server: Starten und Beenden von Services.
Note:
Do not copy the old logs from the backup folder to the newly cleaned directory. If required, explore the old logs from the backup folder.

Artikel-ID: 000032770

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln