PROBLEM

Bei Veröffentlichen gehosteter Feature-Layer in einem Portal werden die Fehler 001362 und 001360 angezeigt.

Last Published: April 25, 2020

Beschreibung

Bei Veröffentlichen gehosteter Feature-Layer in einem Portal werden die folgenden Fehler angezeigt:

Error:   
Error 001362: Manifest konnte nicht aus der hochgeladenen Service-Definition extrahiert werden.
Error:   
Error 001360: Fehler beim Abrufen von Basiselement-Metadaten für das Hochladen der Service-Definition.

Ursache

Für diese Fehler sind unter anderem folgende Ursachen bekannt:

ArcGIS Data Store kann nicht über die eingerichteten SSL-Protokolle mit ArcGIS Server oder Portal for ArcGIS kommunizieren.
Die SSL-Protokolle, die für die Computer mit ArcGIS Data Store, Portal for ArcGIS und ArcGIS GIS Server konfiguriert oder aktiviert wurden, stimmen nicht miteinander überein. Damit die gehosteten Feature-Layer erfolgreich veröffentlicht werden können, müssen alle Computer über dieselben SSL-Protokolle verfügen.

Die Service-Definitionsdatei kann nicht mithilfe von Veröffentlichungswerkzeugen vom Portal in den Ordner "Temp" des ArcGIS-Server-Kontos heruntergeladen werden
Beim Veröffentlichen eines gehosteten Feature-Layers lädt das Veröffentlichungswerkzeug des Hosting-Servers die Service-Definitionsdatei vom Portal in den Ordner "Temp" des Kontos herunter, unter dem der ArcGIS Server-Service auf dem Computer ausgeführt wird.

Dieser Download schlägt unter folgenden Umständen fehl:

  • Das ArcGIS-Server-Service-Konto besitzt nicht die erforderlichen Berechtigungen für den Ordner.
  • Das Laufwerk, auf dem sich der Ordner "Temp" befindet, ist voll.
  • Der Ordner "Temp" enthält mehr als 65.000 Dateien (diese Beschränkung ist vom Betriebssystem abhängig).

Lösung oder Problemumgehung

Verwenden Sie je nach Ursache eine der folgenden Lösungen:

ArcGIS Data Store kann nicht über die eingerichteten SSL-Protokolle mit ArcGIS Server oder Portal for ArcGIS kommunizieren.
  1. Stellen Sie fest, welche SSL-Protokolle von ArcGIS Server und Portal for ArcGIS verwendet werden.
    1. Um festzustellen, welches SSL-Protokoll aktuell von ArcGIS Server verwendet wird, melden Sie sich beim ArcGIS-Server-Administratorverzeichnis (https://..com//admin) als Administrator an.
    2. Klicken Sie auf security > config. Notieren Sie sich die neben SSL Protocols aktivierten TLS-Versionen.
Hinweis:
Die Standard-SSL-Protokolle für die Basisbereitstellung von ArcGIS Enterprise ab Version 10.6.1 sind TLS v1.2 und TLS v1.1.
  1. Um festzustellen, welches SSL-Protokoll aktuell von Portal for ArcGIS verwendet wird, melden Sie sich beim Administratorverzeichnis des Portals (https://..com//portaladmin) als Administrator an.
  2. Klicken Sie auf Security > SSLCertificates. Notieren Sie sich die aktivierten TLS-Versionen, die im Feld Web Server SSL Protocols aufgelistet sind.
Hinweis:
Stellen Sie sicher, dass die ArcGIS Server- und Portal for ArcGIS-Protokolle übereinstimmen. Weitere Informationen zum Festlegen von Protokollen in ArcGIS Server und Portal for ArcGIS finden Sie unter ArcGIS Server: Sichere ArcGIS Server-Kommunikation (für ArcGIS Server) und Portal for ArcGIS: Beschränken von TLS-Protokollen und Cipher Suites (für Portal for ArcGIS).
  1. Aktivieren Sie die Protokolle für die einzelnen Computer.
    1. Öffnen Sie auf dem ArcGIS Server-Computer über das Windows-Startmenü die Anwendung Dienste.
Hinweis:
Sie finden die Anwendung "Dienste", indem Sie sie über das Windows-Startmenü suchen oder im Dialogfeld Start > Ausführen den Text services.msc eingeben und die EINGABETASTE drücken.
  1. Notieren Sie sich den in der Spalte Anmelden als aufgeführten Besitzer des ArcGIS -Server-Service.
  1. Melden Sie sich beim ArcGIS Server-Computer mit dem Konto an, über das der ArcGIS Server-Service ausgeführt wird.
  2. Suchen Sie über das Windows-Startmenü nach Internetoptionen, und klicken Sie darauf.
  3. Durchsuchen Sie auf der Registerkarte Erweitert den Abschnitt Einstellungen, und aktivieren Sie die Kontrollkästchen der in Schritt 1 festgestellten Protokolle.
Hinweis:
Möglicherweise müssen Sie sich zum Ändern dieser Protokolle an die IT-Abteilung wenden.
  1. Wiederholen Sie für die Computer, auf denen Portal for ArcGIS und ArcGIS Data Store installiert ist, die Schritte a bis e.
Die Service-Definitionsdatei kann nicht mithilfe von Veröffentlichungswerkzeugen vom Portal in den Ordner "Temp" des ArcGIS-Server-Kontos heruntergeladen werden
  1. Gewähren Sie dem ArcGIS Server-Konto Vollzugriff auf den Ordner "Temp".
    1. Öffnen Sie auf dem ArcGIS Server-Computer über das Windows-Startmenü die Anwendung Dienste.
    2. Notieren Sie sich den in der Spalte Anmelden als aufgeführten Besitzer des ArcGIS -Server-Service.
    3. Melden Sie sich beim ArcGIS Server-Computer mit dem Konto an, über das der ArcGIS Server-Service ausgeführt wird.
    4. Navigieren Sie im Datei-Explorer von Windows zum Ordner "Temp".
Hinweis:
Der Standardspeicherort des temporären Ordners befindet sich unter "C:\Benutzer\Default\AppData\Local".
  1. Klicken Sie mit der rechten Maustaste auf den Ordner, und klicken Sie auf Eigenschaften > Sicherheit.
  2. Markieren Sie das ArcGIS-Server-Service-Konto, und aktivieren Sie unter Berechtigungen für das Kontrollkästchen neben Vollzugriff. Klicken Sie auf Übernehmen.
  1. Überprüfen Sie den verfügbaren Speicherplatz des Laufwerks, auf dem sich der Ordner "Temp" des ArcGIS-Server-Service-Kontos befindet.
    1. Klicken Sie im Datei-Explorer von Windows mit der rechten Maustaste auf das Laufwerk, auf dem sich der Ordner "Temp" befindet (in der Regel das C-Laufwerk). Klicken Sie auf Eigenschaften.
    2. Überprüfen Sie den hier verfügbaren freien Speicherplatz. Wenn nur wenig oder kein freier Speicherplatz vorhanden ist, klicken Sie auf die Schaltfläche Bereinigen, um nicht benötigte Dateien zu entfernen.
  1. Löschen Sie im Ordner "Temp" gespeicherte Dateien.
    1. Navigieren Sie zum Ordner "Temp". Klicken Sie mit der rechten Maustaste auf den Ordner "Temp", und klicken Sie auf Eigenschaften.
    2. Überprüfen Sie auf der Registerkarte Allgemein die Anzahl der gefundenen Dateien. Wenn diese die Beschränkungen des Betriebssystems überschreitet, entfernen Sie nicht mehr benötigte Dateien.

Artikel-ID: 000019726

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