PROBLEM

Fehler 404 beim Anmelden bei Survey123 for ArcGIS über Portal for ArcGIS

Last Published: May 18, 2022

Beschreibung

Beim Anmelden bei Survey123 for ArcGIS über den App-Launcher für Portal for ArcGIS oder über eine Website wird Fehler 404 mit dem Hinweis, dass die Seite nicht gefunden wurde, zurückgegeben.

Abbildung der Fehlermeldung

Ursache

Die für den App-Launcher oder die Website konfigurierte URL von Survey123 for ArcGIS ist falsch. In den meisten Fällen ist dies darauf zurückzuführen, dass die URL das Verzeichnis "/home" enthält. Dieses ist nämlich die Standardzugriffsseite für die meisten Benutzer von Portal for ArcGIS.

Das richtige URL-Schema für die Anmeldung bei Portal for ArcGIS über die Website von Survey123 for ArcGIS lautet:

https://survey123.arcgis.com/?portalUrl=https://webadaptorhost.domain.com/webadaptor

Bei der Anmeldung wird in der Anforderung die für Portal for ArcGIS angegebene URL mit folgendem Zusatz verwendet:

/sharing/rest/oauth2/authorize?client_id=survey123hub&display=default&redirect_uri=https%3A%2F%2Fsurvey123.arcgis.com%2Fsurveys%3FportalUrl%3Dhttps%3A%252F%252Fwddhsgisl02.dhs.sdc.pvt%252Fportal%252Fhome%252F&parent=https://survey123.arcgis.com&locale=en&response_type=token&expiration=720

Das folgende Beispiel zeigt eine korrekte Anforderung, in der die für Portal for ArcGIS angegebene URL ohne das Verzeichnis "/home" verwendet wird:

https://webadaptorhost.domain.com/webadaptor/sharing/rest/oauth2/authorize?client_id=survey123hub&display=default&redirect_uri=https%3A%2F%2Fsurvey123.arcgis.com%2Fsurveys%3FportalUrl%3Dhttps%3A%252F%252Fwddhsgisl02.dhs.sdc.pvt%252Fportal%252Fhome%252F&parent=https://survey123.arcgis.com&locale=en&response_type=token&expiration=720

Das folgende Beispiel zeigt eine fehlerhafte Anforderung, in der die für Portal for ArcGIS angegebene URL mit dem Verzeichnis "/home" verwendet wird:

https://webadaptorhost.domain.com/webadaptor/home/sharing/rest/oauth2/authorize?client_id=survey123hub&display=default&redirect_uri=https%3A%2F%2Fsurvey123.arcgis.com%2Fsurveys%3FportalUrl%3Dhttps%3A%252F%252Fwddhsgisl02.dhs.sdc.pvt%252Fportal%252Fhome%252F&parent=https://survey123.arcgis.com&locale=en&response_type=token&expiration=720

Lösung oder Problemumgehung

Entfernen Sie in der Portal for ArcGIS-URL das Verzeichnis "/home", und melden Sie sich erneut an.

Artikel-ID: 000023188

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln