PROBLEM

Für eine Datums- und Zeitfrage, die von der ArcGIS Survey123-Web-App übermittelt wurde, werden die Datumsangaben nicht aufgezeichnet

Last Published: April 29, 2022

Beschreibung

Die Datumsangaben, die über das ArcGIS Survey123-Webformular an Datums- und Zeitfragen übermittelt wurden, werden in der Attributtabelle des gehosteten Feature-Layers des Survey nicht erfasst.

Datum und Uhrzeit in der Attributtabelle nicht erfasst

Ursache

Bei den Datums- und Zeitfragen müssen auf dem Formular sowohl das Datum als auch die Uhrzeit eingetragen sein, wenn es über die Web-App übermittelt wird. Wenn nur das Datum oder die Uhrzeit eingetragen ist, wird bei der Übermittlung weder das Datum noch die Uhrzeit allein erfasst. Es ist jedoch möglich, dass die Benutzer mit der ArcGIS Survey123-Web-App das Formular übermitteln und das Feld für Datum und Uhrzeit in der Attributtabelle des gehosteten Feature-Layers des Survey leer bleibt.

Wenn das Datum oder die Uhrzeit nicht eingetragen ist, wird bei der Übermittlung weder das Datum noch die Uhrzeit allein erfasst.

Lösung oder Problemumgehung

Verwenden Sie eine der folgenden Lösungen:

Festlegen der Datums- und Zeitfrage als obligatorisch

Bearbeiten Sie im ArcGIS Survey123 Web Designer die Frage des Typs Datum und Uhrzeit, indem Sie das Kontrollkästchen Dies ist eine erforderliche Frage aktivieren.

Verwenden der Datumsfrage

Wählen Sie in der ArcGIS Survey123-Web-App die Frage des Typs Datum, wenn die Uhrzeit nicht erforderlich ist. Bei dieser Option wird standardmäßig 12:00 Uhr als Uhrzeit erfasst.

Zuweisen von 'now()' als Standardwert

  1. Laden Sie in ArcGIS Survey123 Connect das Survey-Formular herunter, und öffnen Sie es.
Herunterladen des Survey
  1. Klicken Sie im Survey auf XLSForm, um die Fragen zu bearbeiten.
  2. Navigieren Sie im Formular zum dateTime-Feld.
  3. Legen Sie ‘now()’ in der Spalte default für die dateTime-Frage fest. Speichern Sie das Formular, und veröffentlichen Sie es erneut.
Legen Sie ‘now()’ in der Spalte

Artikel-ID: 000026776

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln