PROBLEM

Dataset wird beim Veröffentlichen von Surveys in Portal for ArcGIS nicht gefunden

Last Published: April 27, 2022

Beschreibung

Bei dem Versuch, Surveys von ArcGIS Survey123 Connect oder ArcGIS Survey123 in Portal for ArcGIS zu veröffentlichen, werden folgende Fehlermeldungen ausgegeben:

Error: Dataset nicht gefunden. Status: Fehler. Details: code 500
Error: Fehler beim Abrufen des Ergebnisparameters. Status: Fehler. Details: code 500
Error: Es kann kein neuer Survey erstellt werden. ERROR: Dataset nicht gefunden.
Fehlermeldung in ArcGIS Survey123

Ursache

Die genannten Fehlermeldungen weisen auf ein vielschichtiges Problem hin. Mögliche Fehlerursachen sind unter anderem:

  • In Portal for ArcGIS können keine gehosteten Feature-Layer erstellt werden; diese stellen aber einen zentralen Bestandteil der Veröffentlichung dar.
  • Der Geoverarbeitungsservice "PublishingTools" oder "PublishingToolsEx" wird nicht ausgeführt oder erfordert einen Neustart.
  • Die ArcGIS Data Store-Lizenz ist abgelaufen.
  • ArcGIS Data Store wurde in ArcGIS Server nicht validiert.
  • Dem Benutzer fehlen die Berechtigungen zum Veröffentlichen von gehosteten Feature-Services in ArcGIS Server.
  • Das in Portal for ArcGIS veröffentlichte Survey123-Formular enthält nur eine Geopunkt-Frage, bei der die benutzerdefinierte Spalte "bind::esri:fieldType" auf NULL festgelegt ist. Weitere Informationen finden Sie unter BUG-000137465.

Lösung oder Problemumgehung

  1. Prüfen Sie in Portal for ArcGIS, ob gehostete Feature-Layer veröffentlicht werden können. Testen Sie dies, indem Sie entweder über eine Vorlage oder durch direktes Hochladen einer CSV-Datei einen Layer mit Portal for ArcGIS erstellen.
Hinweis: Wenn der Fehler nicht für alle Survey-Formulare zurückgegeben wird, kann ein Konfigurationsproblem oder ein Problem mit dem XLSForm-Entwurf des Survey vorliegen. Veröffentlichen Sie das Survey-Formular erneut, oder lesen Sie die Empfehlungen für XLSForm-Entwürfe unter ArcGIS Survey123: Grundlegendes zu XLSForm.
  1. Wenn der Fehler weiterhin besteht, prüfen Sie den Status des Geoverarbeitungsservice "PublishingTools" oder "PublishingToolsEx". Weitere Informationen finden Sie unter ArcGIS Server: Starten und Beenden von Services.
  2. Durchsuchen Sie die ArcGIS Server Manager-Protokolle nach der Ursache. Informationen zum Zugriff auf die Protokolle finden Sie unter ArcGIS Server: Serverprotokolle.
    1. Führen Sie das Dienstprogramm "describedatastore.bat" aus. Weitere Informationen zu ArcGIS Data Store-Befehlsdienstprogrammreferenzen finden Sie unter ArcGIS Enterprise: ArcGIS Data Store  – Hinweise zu Dienstprogrammen.
    2. Prüfen Sie den Data Store-Modus, und geben Sie Speicherplatz frei. Wenn der Data Store-Modus auf READONLY eingestellt ist und freier Speicherplatz vorhanden ist, legen Sie den Data Store vom Typ "relational" mit dem folgenden Befehl auf den Modus READWRITE fest.
changedatastoremode readonly|readwrite [--prompt <yes|no>]
Hinweis: Der Data Store-Modus wird zur Vermeidung von Datenverlust automatisch auf READONLY eingestellt, wenn auf dem Computer nur wenig Speicherplatz frei ist.
  1. Starten Sie den ArcGIS Data Store-Service unter Windows neu.
Eingabeaufforderung für

Artikel-ID: 000022129

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