HOW TO

Problem mit der Online-Grundkarte bei ArcGIS Business Analyst Desktop 10.8.2 (rote Ausrufezeichen)

Last Published: May 3, 2024

Beschreibung

Benutzer von Business Analyst können in ArcMap nicht mehr über das Dropdown-Menü "Karten" in der Werkzeugleiste von Business Analyst auf Grundkarten zugreifen. Beim Laden der Layer-Datei "2021 Business Analyst Web - World Street Map.lyr" tritt ein Fehler auf, und im Inhaltsverzeichnis wird ein rotes Ausrufezeichen angezeigt.

Ursache

Im April 2022 wurde die HTTP-Unterstützung für Esri Grundkarten eingestellt, sodass Kachelanforderungen über HTTPS vorgenommen werden müssen. Für Benutzer von Business Analyst in ArcGIS Pro erfolgt diese Änderung automatisch, und sie sollte keine Auswirkungen auf die tägliche Verwendung von LYR-Dateien und von Online-Grundkarten von Esri haben.

Benutzer von ArcMap werden dagegen möglicherweise feststellen, dass Grundkarten in vorhandenen MXD-Dokumenten nicht geladen werden und dass im Inhaltsverzeichnis an entsprechender Stelle ein rotes Ausrufezeichen angezeigt wird. Diese Karten wurden möglicherweise über eine LYR-Datei oder über das Dropdown-Menü in der Werkzeugleiste von Business Analyst geladen. Anhand der Layer-Eigenschaften für diese defekten Layer können Benutzer erkennen, dass die Quelle auf eine HTTP-URL verweist.

Lösung oder Problemumgehung

Ab Version 2022 der Business Analyst-Daten verweist die Layer-Datei "2021 Business Analyst Web - World Street Map.lyr" auf eine HTTPS-URL, die in ArcMap und ArcGIS Pro ordnungsgemäß geladen wird.

Für ArcMap-Benutzer, die andere Grundkarten-Angebote von Esri nutzen möchten, gibt es zwei Lösungen:

  • Laden Sie Grundkarten, indem Sie in der Hauptwerkzeugleiste auf Daten hinzufügen > Grundkarten klicken. Die Dropdown-Liste Karten in der Business Analyst-Werkzeugleiste funktioniert nicht ordnungsgemäß, da damit HTTP zum Anfordern von Grundkartenkacheln verwendet wird.
  • Suchen Sie nach dem Grundkarten-Layer, bei dem beim Zeichnen Fehler auftreten, und öffnen Sie die Layer-Eigenschaften.
  1. Klicken Sie auf der Registerkarte Quelle auf Datenquelle festlegen, und navigieren Sie zu Serververbindungenim Dateibrowser-Pop-up. Erstellen Sie eine neue ArcGIS-Server-Verbindung mit:
https://services.arcgisonline.com/arcgis/services
  1. Klicken Sie auf diese Serververbindung, um die gewünschte Grundkarte auszuwählen.

Damit sollte die Datenquelle repariert werden und die Verwendung der gewünschten Esri-Grundkarte in ArcMap möglich sein.

Artikel-ID: 000028169

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln