PROBLEM

Beim Aktualisieren von ArcGIS Survey123 auf Version 3.12 auf einem Android-Gerät ist ein Fehler aufgetreten

Last Published: April 27, 2022

Beschreibung

Im Google Play Store wurden Anforderungen implementiert, um die Sicherheit der Daten zu verbessern, die von auf Geräten gespeicherten Anwendungen verwendet werden Zuvor hatten installierte Anwendungen sowohl auf den "öffentlichen" Speicher als auch den anwendungsspezifischen "privaten" Speicher auf dem Gerät Zugriff. Android-Entwickler sprechen hierbei von "externem" und "bereichsbezogenem" (scoped) Speicher. Anwendungen müssen jetzt sämtliche Daten im bereichsbezogenen (privaten) Speicher ablegen.

Die Version 3.12 von ArcGIS Survey123 verfügt über einen automatischen Migrationsprozess, der beim ersten Öffnen der Anwendung gestartet wird. Mit diesem Prozess werden die ursprünglichen Daten der Version 3.11, einschließlich Surveys und Benutzereinstellungen, in den bereichsbezogenen Speicher migriert. Es kann vorkommen, dass die Migration fehlschlägt und ein Fehlercode zurückgegeben wird.

Ursache

Es gibt verschiedene Gründe für das Fehlschlagen der Android-Speichermigration. Weitere Informationen hierzu finden Sie unten in der Liste der Fehlercodes und Beschreibungen.

Lösung oder Problemumgehung

In der Tabelle unten finden Sie zu jedem Fehlercode die entsprechenden Lösungsschritte.

Im Rahmen des Migrationsprozesses wird von Survey123 eine Protokolldatei mit dem Namen "migration.log" im ursprünglichen ArcGIS-Ordner auf dem Android-Gerät erstellt (üblicherweise unter /Internal storage/ArcGIS, /sdcard/ArcGIS, /storage/emulated/0/ArcGIS oder ähnlich).

Hinweis: Wenn das Problem nicht mit Hilfe der Lösungsschritte behoben werden kann, bewahren Sie eine Kopie der Protokolldatei auf, und wenden Sie sich an den Esri Support Service, um weitere Hilfe zu erhalten.
CodeBeschreibungLösungsschritte
2900Anwendungsausnahme aufgrund eines unbekannten FehlersStellen Sie eine Kopie der Protokolldatei zur Verfügung, und wenden Sie sich an den Esri Support, um weitere Hilfe zu erhalten.
2901Speicherzugriffsberechtigung abgelehnt. Der Benutzer hat den Zugriff auf das Speichergerät durch die Anwendung verweigert.Starten Sie die Anwendung neu. Es wird ein Dialogfeld angezeigt, in dem Sie um die Berechtigung zum Zugriff auf das Speichergerät gebeten werden. Die Berechtigung muss erteilt werden, damit die Migration fortgesetzt werden kann.
2902ArcGIS-Datenordner im Legacy-Speicher nicht gefundenDen gültigen Pfad zum alten ArcGIS-Ordner finden Sie in der Fehlermeldung in der Protokolldatei. Vergewissern Sie sich, dass dieser Ordner an dem betreffenden Speicherort vorhanden ist.
2903Überprüfung fehlgeschlagen, da die Datei am Zielspeicherort nicht vorhanden istInformationen darüber, welche Datei am neuen Speicherort erwartet aber nicht gefunden wurde, finden Sie in der Fehlermeldung in der Protokolldatei.
2904Überprüfung fehlgeschlagen, da die Dateigröße nicht übereinstimmtInformationen darüber, welche Datei am alten und neuen Speicherort eine unterschiedliche Größe aufweist, finden Sie in der Fehlermeldung in der Protokolldatei.
2905Das Speichergerät verfügt nicht über genügend freien SpeicherplatzInformationen zum gesamten Speicherplatz des Speichergeräts, zum verfügbaren Speicherplatz und zur Größe der ArcGIS-Ordner, die im Rahmen der Migration kopiert werden müssen, finden Sie in der Fehlermeldung in der Protokolldatei. Der mindestens erforderliche Speicherplatz beträgt das Doppelte der Größe der ArcGIS-Ordner. Geben Sie auf dem Gerät manuell Speicherplatz frei, damit die Migration ausgeführt werden kann.
2906Die Datei mit den Legacy-Einstellungen konnte nicht entfernt werdenStellen Sie sicher, dass keine andere Instanz von Survey123 geöffnet ist und dass keine andere Anwendung Dateien oder Ordner am alten ArcGIS-Speicherort geöffnet hat. Führen Sie die Migration erneut aus.
2907Ordner am Zielspeicherort konnte nicht erstellt werdenStarten Sie die Anwendung neu. Es wird ein Dialogfeld angezeigt, in dem Sie um die Berechtigung zum Zugriff auf das Speichergerät gebeten werden. Die Berechtigung muss erteilt werden, damit die Migration fortgesetzt werden kann.
2908Vorhandenes ZIP-Archiv konnte nicht entfernt werdenStellen Sie sicher, dass keine andere Instanz von Survey123 geöffnet ist und dass keine andere Anwendung Dateien oder Ordner am alten ArcGIS-Speicherort geöffnet hat. Führen Sie die Migration erneut aus.
2909Das Entfernen des Ordners aus dem Legacy-Speicher ist fehlgeschlagenStellen Sie sicher, dass keine andere Instanz von Survey123 geöffnet ist und dass keine andere Anwendung Dateien oder Ordner am alten ArcGIS-Speicherort geöffnet hat. Führen Sie die Migration erneut aus.
2910Nach der Dateimigration ist die Datenbank nicht im bereichsbezogenen Speicher vorhandenVergewissern Sie sich vor dem Migrationsprozess, dass die Survey-Datenbankdatei am alten Speicherort vorhanden ist.
2911Die Kartenbibliothekspfade konnten in der Einstellungsdatei nicht aktualisiert werdenStellen Sie sicher, dass die Einstellungsdatei am bereichsbezogenen Speicherort vorhanden ist, und dass sie von keiner anderen Anwendung geöffnet wurde. Führen Sie die Migration erneut aus.
2912Datendatei konnte nicht in den bereichsbezogenen Speicher kopiert werdenStarten Sie die Anwendung neu. Es wird ein Dialogfeld angezeigt, in dem Sie um die Berechtigung zum Zugriff auf das Speichergerät gebeten werden. Die Berechtigung muss erteilt werden, damit die Migration fortgesetzt werden kann.
2913Datendatei konnte nicht über eine vorhandene Datei im bereichsbezogenen Speicher kopiert werdenStellen Sie sicher, dass keine andere Instanz von Survey123 geöffnet ist und dass keine andere Anwendung Dateien oder Ordner am bereichsbezogenen Speicherort geöffnet hat. Führen Sie die Migration erneut aus.
2914Die Einstellungsdatei konnte nicht für die Aktualisierung geöffnet werdenStellen Sie sicher, dass die Einstellungsdatei am bereichsbezogenen Speicherort vorhanden ist, und dass sie von keiner anderen Anwendung geöffnet wurde. Führen Sie die Migration erneut aus.
2915Pfade für bekannte Geräte konnten nicht aktualisiert werdenStellen Sie sicher, dass die Einstellungsdatei am bereichsbezogenen Speicherort vorhanden ist, und dass sie von keiner anderen Anwendung geöffnet wurde. Führen Sie die Migration erneut aus.
2917Datei konnte dem ZIP-Archiv nicht hinzugefügt werdenFühren Sie die Migration erneut aus.
2918Die Protokolldatei konnte nicht zum Schreiben geöffnet werdenVergewissern Sie sich, dass der Speicherort für die Legacy-Daten existiert.
2919Nach der Dateimigration ist die Einstellungsdatei nicht im bereichsbezogenen Speicher vorhandenVergewissern Sie sich, dass die Survey123-Einstellungsdatei am alten Speicherort vorhanden ist.
2920Während des Flugvorbereitungstests konnte der bereichsbezogene Speicher nicht gelesen werdenVergewissern Sie sich, dass der erwartete bereichsbezogene Speicherort existiert.
2921Während des Flugvorbereitungstests konnte nicht in den bereichsbezogenen Speicher geschrieben werdenVergewissern Sie sich, dass der erwartete bereichsbezogene Speicherort existiert.
2922Während des Flugvorbereitungstests konnte nicht in den bereichsbezogenen Speicher geschrieben werdenVergewissern Sie sich, dass der erwartete bereichsbezogene Speicherort existiert.
2923Während des Flugvorbereitungstests konnte nicht in den bereichsbezogenen Speicher geschrieben werdenVergewissern Sie sich, dass der erwartete bereichsbezogene Speicherort existiert.
2924Während des Flugvorbereitungstests konnte nicht in den bereichsbezogenen Speicher geschrieben werdenVergewissern Sie sich, dass der erwartete bereichsbezogene Speicherort existiert.
2925Während des Flugvorbereitungstests konnte nicht in den bereichsbezogenen Speicher geschrieben werdenVergewissern Sie sich, dass der erwartete bereichsbezogene Speicherort existiert.
2926ZIP-Archiv konnte nicht geschrieben werdenFühren Sie die Migration erneut aus.

Artikel-ID: 000025129

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln