PROBLEM

Patches für die Portal for ArcGIS-Komponente von ArcGIS Enterprise frieren unter Windows ein.

Last Published: August 4, 2021

Beschreibung

Bei einigen Windows-Systemen wird bei der Installation von Patches für die Portal for ArcGIS-Komponente von ArcGIS Enterprise möglicherweise die Meldung "Installer reagiert nicht mehr" angezeigt.

Installer-Meldung

Ursache

Die Portal for ArcGIS-Komponente enthält eine große Anzahl an Dateien. Außerdem wird eine vollständige Liste mit allen installierten Dateien von der Installationstechnologie verwaltet. Durch die Verwaltung dieser Liste bei der Installation von Patches kommt es zu einem deutlichen Overhead, der bei langsameren Computern oder VMs dazu führen kann, dass Vorgänge länger dauern, als die Windows Installer-Technologie erwartet.  

Lösung oder Problemumgehung

Es gibt mehrere Mechanismen, um dieses Problem zu vermeiden oder zu minimieren.

  1. Verwenden Sie, wenn möglich, die /qn-Option für automatische Installationen. So wird das Problem komplett vermieden.  
     
    Führen Sie über eine Eingabeaufforderung der oberen Ebene den folgenden Befehl aus:

    <patchname.msp> /qn

    Beispiel:

    ArcGIS-109-S-ALPI-Patch.msp /qn
  1. Wenn Sie die Warnung "Installer reagiert nicht mehr" während der interaktiven Installation eines Patches erhalten, klicken Sie einfach auf "Wiederholen". Auf einigen Systemen kann die Warnung mehrfach auftreten. Sie können den Vorgang in allen Fällen fortsetzen. Der Installer wird den Vorgang letztendlich abschließen.

Versuchen Sie, alle Prozesse zu deaktivieren, die Dateioperationen verlangsamen können, wie z. B. Anti-Virus-Software und andere Sicherheitssoftware. Hierdurch wird die Wahrscheinlichkeit verringert, dass dieses Problem auftritt.  

Verwenden Sie die schnellste Speichermöglichkeit für das Installationsverzeichnis, wie SSD-gestützten Speicher. Durch die schnellere Suchzeit bei dem SSD-gestützten Speicher wird die Installationszeit deutlich reduziert und die Wahrscheinlichkeit verringert, dass dieses Problem auftritt.

Artikel-ID:000026175

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln