PROBLEM

Neue Monitor-Agenten können nach dem Upgrade auf ArcGIS Monitor 2023.3.1 nicht hinzugefügt werden

Last Published: January 20, 2025

Beschreibung

Nach dem Upgrade auf ArcGIS Monitor 2023.3.1 können neue Agenten mit dem folgenden Fehler nicht hinzugefügt werden:

"Failed to fetch".

Bild des Fehlers beim Verbinden mit dem Monitor-Server

Ursache

 

Beim Untersuchen des Netzwerkdatenverkehrs wird ein CORS-Fehler (Cross-Origin Request Blocked) zurückgegeben, wie in der nächsten Abbildung gezeigt:

image001.png

Der CORS-Fehler weist darauf hin, dass die Anforderung vom Agent-Computer an den Server-Computer zum Abrufen eines Token blockiert ist und die Registrierung aufgrund eines Netzwerkfehlers fehlschlägt.

Lösung oder Problemumgehung

Wenn Sie die Admin-URL zur Überwachung der Site auf dem Agent-Computer geöffnet und sich angemeldet haben, konnte der neue Agent weiterhin über eine andere Browser-Registerkarte registriert werden.

  1. Öffnen Sie auf dem Agent-Computer eine neue Registerkarte im Browser, und navigieren Sie zur Seite "Monitor Server Site Admin".
  2. Melden Sie sich bei der Monitor Server-Site an.
  3. Kehren Sie zur Registerkarte zurück, um den Agenten zu registrieren, und klicken Sie auf die Schaltfläche Weiter, ohne dass der Fehler "Fehler beim Abrufen" angezeigt wird.

Artikel-ID: 000032368

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln