BUG

Beim Tippen auf die Schaltfläche "Analyse" in einer Webkarte wird das Fenster "Analyse durchführen" auf einem Touchscreen-Gerät nicht geöffnet

Last Published: April 24, 2024

Beschreibung

In version 10.5 of Portal for ArcGIS, when connected to the portal from a touch screen device, the Analysis button is unresponsive from the main menu or from a layer’s context menu.

Ursache

This is a known issue. In a web map, pressing the Analysis button does not open the Perform Analysis panel on a touch screen device.

Problemumgehung

This issue is planned to be addressed in the 10.5.1 release of Portal for ArcGIS.

To allow users with touchscreen devices to perform analysis in version 10.5, the configuration file must be edited. This file is located on the machine where Portal for ArcGIS is installed. Click the following web help link to learn more about this file: Editing the configuration file for Portal for ArcGIS.

The instructions provided describe how to edit the configuration file for Portal for ArcGIS.

Note:
Make a backup copy of your config.js file before modifying it.
  1. Using an administrator account, log in to the server where Portal for ArcGIS is installed.
  2. Stop the Portal for ArcGIS service.
  3. Use File Explorer to navigate to the config.js file. The configuration file is located at: 
    • <Portal for ArcGIS installation directory>\ customizations\<version number>\webapps\arcgis#home\js\arcgisonline\config.js
  4. Open the config.js file in a text editor, such as Notepad or Notepad++.
  5. Add the following package references to the config.js file.
    Note:
    Unless the file has been edited, the following text should be added starting at line 559.
    
    {
       name: "dgrid1",
      location: "../../jsapi/dgrid1"
    },
    {
      name: "dstore",                                                    
       location: "../../jsapi/dstore"
    },
    • Once this text is added, the file looks like the following (see highlighted section in the image below):

      Updated Portal Config
  6. Save the file.
  7. Restart Portal for ArcGIS.
  8. On a touch screen device, refresh the web browser.

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