PROBLEM

Graphics card conflict may cause ArcMap to crash

Last Published: April 25, 2020

Beschreibung

ArcMap kann aus verschiedenen Gründen abstürzen. Zu einem Absturz kann es zum Beispiel beim Laden der Datenansicht, beim Öffnen und bei einer umfangreichen Verarbeitung kommen. Einer der Aspekte, die zu berücksichtigen sind, wenn ArcMap abstürzt, besteht darin, dass externe Probleme unsere Software beeinflussen und diese Abstürze verursachen können. ArcMap stützt sich stark auf die Möglichkeiten, die die Grafikkarten bieten. Auf einem Windows 7-Computer finden Sie die Grafikkarten, indem Sie die folgenden Schritte ausführen:

  1. Navigieren Sie zu Start > Systemsteuerung.
  2. Klicken Sie auf Geräte-Manager.
Hinweis: Für den Zugriff auf den Geräte-Manager sind möglicherweise Administratorberechtigungen erforderlich. Bestimmte Kunden besitzen möglicherweise ausreichende Berechtigungen zum Anzeigen, können aber keine Änderungen vornehmen.
Screenshot des Abschnitts
  1. Erweitern Sie den Knoten Grafikkarten. Wenn mehr als ein Element aufgelistet ist, dann können Abstürze von ArcMap durch einen Konflikt zwischen diesen Grafikkarten verursacht werden.

Ursache

Manchmal kann ein Konflikt zwischen Grafikkarten einen Absturz von ArcMap verursachen. Am häufigsten wurde dies beobachtet, wenn ein Computer eine dedizierte Grafikkarte zusätzlich zu einer integrierten Grafikkarte enthält (z. B. Intel mit AMD FirePro). Dies lässt sich überprüfen, indem die eine Karte deaktiviert wird, während die andere Karte aktiviert bleibt, der Computer neu gestartet wird und ArcMap geöffnet wird, um festzustellen, ob dieses Problem behoben ist. Der Benutzer sollte auch versuchen, die erste Karte wieder zu aktivieren und die zweite Karte zu deaktivieren, dann neu zu starten und ArcMap zu öffnen. Wenn das Problem durch Deaktivieren der einen oder der anderen Karte behoben werden kann, dann könnte dies darauf hinweisen, dass die Grafikkarten dafür verantwortlich sind.

Lösung oder Problemumgehung

Die Fehlerbehebung bei Videokarten gehört zwar nicht zum Support-Umfang von Esri Support Services. Dennoch sind die folgenden drei Lösungen zum Beheben dieser Probleme bekannt. Esri empfiehlt, bei diesen Schritten die IT-Abteilung zur Genehmigung von Änderungen am Computer einzubeziehen:

  • Mit einer Reihe von Schritten zum Deaktivieren, erneuten Aktivieren und erneuten Starten lässt sich der Computer möglicherweise so weit aktualisieren, dass ArcMap ermitteln kann, welche Karte beim Starten und Anzeigen von Daten verwendet werden muss:
  1. Deaktivieren Sie die erste Karte.
  2. Starten Sie den Computer neu.
  3. Öffnen Sie ArcMap.
  4. Aktivieren Sie die erste Karte.
  5. Deaktivieren Sie die zweite Karte.
  6. Starten Sie den Computer neu.
  7. Öffnen Sie ArcMap.
  8. Aktivieren Sie die zweite Karte wieder.
  9. Starten Sie den Computer neu.
  10. Öffnen Sie ArcMap.
  • Der Kunde sollte auch sicherstellten, dass die aktuelle Version der Grafikkartentreiber des jeweiligen Herstellers verwendet wird.
  • Wenn mit AMD FirePro Probleme auftreten, dann kann der Kunde möglicherweise das AMD Catalyst Control Center so konfigurieren, dass "arcmap.exe" im High Performance-Modus ausgeführt wird.
Screenshot der zeigt, dass

Artikel-ID: 000013717

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln