Fehlermeldung
Versuche, einen Webszenen-Layer aus ArcGIS Pro zu veröffentlichen, schlagen fehl, und die folgende Fehlermeldung wird zurückgegeben:
Error: Das Portal unterstützt nicht die Veröffentlichung von Webszenen-Layern.
Ursache
Portal for ArcGIS kann keine Verbindung zum Data Store vom Typ "Kachel-Cache" herstellen.
Lösung oder Problemumgehung
Rekonfigurieren Sie den Data Store vom Typ "Kachel-Cache", und stellen Sie sicher, dass die erforderlichen Ports in der ArcGIS Enterprise-Umgebung geöffnet sind, sodass alle Komponenten ordnungsgemäß miteinander kommunizieren können.
Warnung: Mit der folgenden Lösung werden Daten aus dem Data Store gelöscht. Esri empfiehlt, eine Datensicherung durchzuführen, bevor Sie mit den folgenden Schritten fortfahren.
- Führen Sie die Windows-Eingabeaufforderung als Administrator aus.
- Navigieren Sie zum Ordner der ArcGIS Data Store-Dienstprogramme:
C:\Programme\ArcGIS\DataStore\tools
- Führen Sie mit dem folgenden Befehl das Dienstprogramm unregisterdatastore aus, um die Registrierung des Kachel-Cache-Data-Store aufzuheben:
unregisterdatastore.bat –stores tileCache –prompt yes
- Deinstallieren Sie ArcGIS Data Store. Eine Anleitung hierzu finden Sie unter ArcGIS Enterprise: Deinstallieren von ArcGIS Data Store.
- Benennen Sie im folgenden Verzeichnis den Ordner DataStore in DataStore_Old um:
C:\Program Files\ArcGIS\DataStore
- Installieren Sie die aktuelle Version von ArcGIS Data Store. Eine Anleitung hierzu finden Sie unter ArcGIS Enterprise: Installieren von ArcGIS Data Store.
- Erstellen Sie mithilfe des Data Store-Konfigurationsassistenten einen Data Store vom Typ "Kachel-Cache". Eine Anleitung hierzu finden Sie unter ArcGIS Enterprise: Erstellen eines Data Store.
- Öffnen Sie alle Ports, die für die Kommunikation von ArcGIS Data Store mit den anderen ArcGIS Enterprise-Komponenten erforderlich sind. Weitere Informationen finden Sie unter ArcGIS Enterprise: Firewall-Einstellungen und ArcGIS Enterprise: Diagramm der in einer ArcGIS Enterprise-Bereitstellung verwendeten Ports.