Beschreibung
Beim Versuch, sich mit Security Assertion Markup Language (SAML) bei ArcGIS Enterprise anzumelden, wird der folgende Fehler zurückgegeben:
Error:
Unable to login using Idp. IDP supports Encrypted SAML Assertion, but sends unencrypted Assertion
Ursache
- Die Option "Assertion verschlüsseln" ist in Portal for ArcGIS aktiviert.
- Das samlcert-Zertifikat wird nicht in das IDP-Portal (Identity-Provider) importiert.
Lösung oder Problemumgehung
Deaktivieren der Option "Assertion verschlüsseln"
- Melden Sie sich bei Portal for ArcGIS an, und klicken Sie auf Organisation > Einstellungen > Sicherheit.
- Wählen Sie im Abschnitt Anmeldungen den IDP aus.
- Erweitern Sie auf der Seite Eigenschaften angeben die Option Erweiterte Einstellungen anzeigen.
- Deaktivieren Sie die Option Assertion verschlüsseln.
- Klicken Sie auf Speichern.
Importieren des samlcert-Zertifikats in das IDP-Portal
Note:
The following workaround may require the assistance of the organization's IT team.
- Deaktivieren Sie die Option "Assertion verschlüsseln".
- Melden Sie sich bei Portal for ArcGIS an, und klicken Sie auf Organisation > Einstellungen > Sicherheit.
- Wählen Sie im Abschnitt Anmeldungen den Identity-Provider aus.
- Erweitern Sie auf der Seite Eigenschaften angeben die Option Erweiterte Einstellungen anzeigen.
- Deaktivieren Sie die Option Assertion verschlüsseln.
- Klicken Sie auf Speichern.
- Exportieren Sie das samlcert-Zertifikat.
- Melden Sie sich beim ArcGIS-Portal-Administratorverzeichnis an.
- Klicken Sie auf Sicherheit > SSLCertificates.
- Klicken Sie auf das vorhandene samlcert-Zertifikat.
- Klicken Sie auf Exportieren.
- Importieren Sie das samlcert-Zertifikat in das IDP-Portal, und suchen Sie die Einstellungen für die Token-Verschlüsselung.
- Aktivieren Sie das samlcert-Zertifikat, nachdem es importiert wurde.
- Aktivieren Sie die Option "Assertion verschlüsseln".
- Melden Sie sich bei Portal for ArcGIS an, und klicken Sie auf Organisation > Einstellungen > Sicherheit.
- Wählen Sie im Abschnitt Anmeldungen den IDP aus.
- Erweitern Sie auf der Seite Eigenschaften angeben die Option Erweiterte Einstellungen anzeigen.
- Aktivieren Sie die Option Assertion verschlüsseln.
- Klicken Sie auf Speichern.
- Löschen Sie den Browser-Cache, und melden Sie sich mit der SAML-Anmeldung wieder an.