Fehlermeldung
In Portal for ArcGIS Map Viewer, attempting to access an analysis service tool fails with the following error message:
Error:
Unable to access the analysis service
Note:
This error may appear when using the tool for the first time after upgrading Portal for ArcGIS.
Ursache
This error may be caused by an incorrect federation between the ArcGIS Server site and Portal for ArcGIS. An example of a wrong federation configuration is a wrongly referenced Services URL.
Common causes for the error include:
- ArcGIS Server and Portal for ArcGIS federation is misconfigured during an update.
- Federation is performed using the Portal for ArcGIS web adaptor instead of the Server web adaptor.
- The hosting server is not validated.
- A hosting server is not set.
- The URLs used for the Analysis Service are not updated in the ArcGIS Portal Directory.
As a result, the user loses access to the analysis tools, hence, the error.
Lösung oder Problemumgehung
Resolve the error by completing one of the following workarounds:
- Configure the ArcGIS Server and Portal for ArcGIS federation using two web adaptors, one for each software.
- Check the validation status of the federated hosting server.
- Capture the web traffic on a web browser using the built-in browser developer tools.
- Update the URLs used for the Analysis Service in the ArcGIS Portal Directory.
Configure the ArcGIS Server and Portal for ArcGIS federation using two web adaptors, one for each software
- To configure the web adaptors, refer to ArcGIS Enterprise: Configure ArcGIS Web Adaptor for more information.
- Federate the ArcGIS Server site with Portal for ArcGIS. Refer to Portal for ArcGIS: Federate an ArcGIS Server site with your portal for more details.
Check the validation status of the federated hosting server
- Sign in to Portal Administrator Directory and click Federation > Servers. Select the hosting server and click Validate. A successfully validated server shows Status: success. Refer to ArcGIS REST API: Validate Server for more information.
- In Portal for ArcGIS Map Viewer, test the accessibility of the Analysis tools.
Capture the web traffic on a web browser using built-in browser developer tools
If the issue persists, use the developer console window on the web browser to capture the Network traffic in Portal for ArcGIS.
Note:
The following steps are carried out using Google Chrome Developer Tools.
- Open the developer console window in Google Chrome and click the Network tab.
- Sign in to the Portal for ArcGIS home page. In Portal for ArcGIS Map Viewer, click Analysis. In the developer console window, find the .json file in the Name section, and inspect the resource details on the Headers tab. The Request URL must be identical to the URL set when the server is federated.
- If the Request URL is different, check the Hosting Server set in Portal for ArcGIS. To do so, click Organization > Settings > Servers, and take note of the server name under Hosting Server.
- Log in to the ArcGIS Server Administrator Directory of the hosting server identified in Step 3. Click Admin > security > config, and verify the Server role is set to HOSTING_SERVER.
- If the Server role in the ArcGIS Server Administrator Directory states FEDERATED_SERVER, proceed with the following:
- Remove the hosting server from Portal for ArcGIS.
- Refresh the ArcGIS Server Administrator Directory, and specify the hosting server in Portal for ArcGIS.
- Refresh the ArcGIS Server Administrator Directory, and ensure the Server role is updated to HOSTING_SERVER.
- In Map Viewer, test the accessibility of the Analysis tools.
Update the URLs used for the Analysis Service in the ArcGIS Portal Directory
- Log in to the ArcGIS Portal Directory.
- Browse to Home > Portals > Self.
- Check the helperServices URLs and update these if they are not correct:
- Browse to Supported Operations at the bottom of the self page and click Update.
- In the Update dialog box, browse to the helper service property, and paste the URL.