ERROR

Die Benutzer-ID [userID] stimmt mit keinem Named User in Ihrer Organisation überein und ist in Ihrem Projekt aktiv. Lesen Sie weitere Informationen zum Entfernen des Benutzers aus diesem Projekt

Last Published: September 30, 2022

Fehlermeldung

Wenn ein Administrator versucht, einen Benutzer mit der Rolle als Außendienstmitarbeiter in einem Workforce for ArcGIS-Projekt zu entfernen, wird die folgende Fehlermeldung zurückgegeben:

Error: 
Die Benutzer-ID [userID] stimmt mit keinem Named User in Ihrer Organisation überein und ist in Ihrem Projekt aktiv. Lesen Sie weitere Informationen zum Entfernen des Benutzers aus diesem Projekt.

Auf der Registerkarte "BENUTZER" wird die Benutzer-ID des Außendienstmitarbeiters als ungültig angezeigt, obwohl die Rolle in der Anwendung Workforce for ArcGIS als "Aktiv" angezeigt wird. Wenn auf die Registerkarte "BENUTZER" geklickt wird, wird in bestimmten Fällen kein Inhalt angezeigt. Die folgenden Abbildungen zeigen die Fehlermeldung mit der ungültigen Benutzer-ID und dem fehlenden Inhalt.
Image with error message

Image with blank content

Ursache

Dieses Problem tritt auf, wenn der Benutzer mit der Rolle als Außendienstmitarbeiter bestimmte Arbeiten, die ihm in einem Projekt zugewiesen wurden, begonnen oder abgeschlossen hat, oder die Zuweisung von Arbeiten gerade stattfindet.

Lösung oder Problemumgehung


Verwenden Sie einen der folgenden Workarounds, um Benutzer mit der Rolle als Außendienstmitarbeiter in der Anwendung Workforce for ArcGIS zu löschen:

Für Aufträge, die nicht gestartet oder abgeschlossen wurden
Weisen Sie den Auftrag einem anderen Benutzer mit der Rolle als Außendienstmitarbeiter zu, und löschen Sie den vorherigen Benutzer in der Anwendung Workforce for ArcGIS. Eine ausführlichere Anleitung finden Sie unter Workforce for ArcGIS-Webhilfe: Neuzuweisen von Aufträgen.

Für Aufträge, die gerade ausgeführt werden oder abgeschlossen wurden
Weisen Sie den Auftrag auf Feature-Service-Ebene in ArcGIS Online zu. Gehen Sie folgendermaßen vor:

  1. Klicken Sie in ArcGIS Online auf Inhalt > Eigene Inhalte, und navigieren Sie zu Ordner.

    Content and My Content pane
     
  2. Klicken Sie auf den Ordner, in dem der gewünschte Workforce for ArcGIS-Auftrag enthalten ist, und klicken Sie auf den Außendienstmitarbeiter-Feature-Layer.

    Folder and worker feature layer pane
     
  3. Klicken Sie auf Daten > Tabelle und dann auf die Schaltfläche Optionen. Wählen Sie Spalten ein-/ausblenden aus.

    Data and table pane with the option button
     
  4. Aktivieren Sie das Kontrollkästchen ObjectID. Identifizieren Sie die ObjectID des vorherigen Benutzers, der gelöscht werden soll, und des neuen Benutzers, dem der Auftrag zugewiesen werden soll.

    ObjectID check box
    ObjectID of users
Hinweis:
Außendienstmitarbeiter werden über die ObjectID identifiziert. Die ObjectID wird verwendet, um die WorkerID des Auftrags zu ändern.
  1. Öffnen Sie den Zuweisungs-Layer in Map Viewer, und legen Sie die WorkerID des Auftrags auf die ID des neuen Benutzers fest:
    1. Öffnen Sie den Auftrag in Map Viewer, und klicken Sie im Bereich Inhalt auf Tabelle anzeigen.

      Contents pane
       
    2. Doppelklicken Sie in der Tabelle auf die WorkerID des Auftrags, um die ObjectID auf die ID des neuen Außendienstmitarbeiters festzulegen, und klicken Sie auf Speichern.

      Table with WorkerID
       
  2. Öffnen Sie Workforce for ArcGIS, und löschen Sie den vorherigen Benutzer.

Artikel-ID: 000019491

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln