ERROR

Die Aktion kann nicht abgeschlossen werden, da der Ordner oder eine darin enthaltene Datei in einem anderen Programm geöffnet ist

Last Published: March 30, 2021

Fehlermeldung

Eine gängige Praxis bei der Neuinstallation oder Softwarereparatur von ArcGIS Enterprise besteht darin, eine saubere Deinstallation der Software vorzunehmen. In einigen Fällen wird die saubere Deinstallation von ArcGIS Enterprise-Komponenten, wie z. B. Portal for ArcGIS, ArcGIS Server und ArcGIS Data Store, nicht abgeschlossen, da die Programmdateien nicht gelöscht werden können. Bei dem Versuch, die Programmordner der Komponenten vom lokalen Computer zu löschen, wird die folgende Fehlermeldung zurückgegeben:

Error: Die Aktion kann nicht abgeschlossen werden, da der Ordner oder eine darin enthaltene Datei in einem anderen Programm geöffnet ist
Die Abbildung zeigt folgende Fehlermeldung, die bei dem Versuch, die ArcGIS Enterprise Data Store-Komponente zu deinstallieren, ausgegeben wird: Die Aktion kann nicht abgeschlossen werden, da der Ordner oder eine darin enthaltene Datei in einem anderen Programm geöffnet ist.

Ursache

Die Dienste der ArcGIS Enterprise-Komponenten sind auch dann noch in den Windows-Diensten vorhanden, nachdem die zugehörigen Komponenten deinstalliert und vom Computer entfernt wurden.

Lösung oder Problemumgehung

Führen Sie den nachstehenden Workflow aus, um den Fehler zu beheben.

Warnung: Mit den folgenden Anweisungen werden Änderungen an entscheidenden Teilen Ihres Betriebssystems vorgenommen. Esri empfiehlt vor dem Durchführen der nächsten Schritte eine Sicherung des Betriebssystems und der Dateien sowie der Registrierung zu erstellen. Für die Ergebnisse bei falschen Modifikationen, die mit diesen Anweisungen vorgenommen werden, kann Esri keine Garantie übernehmen. Lassen Sie Vorsicht walten. Wenden Sie sich bei Bedarf an einen Fachmann für Computersysteme.
  1. Schließen Sie alle ArcGIS-Anwendungen auf dem Computer.
  2. Öffnen Sie das Windows-Startmenü.
  3. Geben Sie in der Suchleiste regedit ein, und drücken Sie die Eingabetaste. Wenn Sie dazu aufgefordert werden, klicken Sie im Fenster Benutzerkontensteuerung auf Ja.
Abbildung mit der Suche nach
  1. Blenden Sie im Fenster Registrierungs-Editor den Eintrag HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services ein.
  2. Klicken Sie mit der rechten Maustaste auf den Ordner ArcGIS Data Store, und klicken Sie auf Exportieren, um eine Kopie zu speichern.
Die Exportauswahl im Fenster
  1. Klicken Sie mit der rechten Maustaste auf den Ordner ArcGIS Data Store, und klicken Sie auf Löschen, um den Ordner zu löschen.
  2. Wiederholen Sie Schritte 4 bis 6 für die Ordner ArcGIS Server und Portal for ArcGIS.
  3. Starten Sie den Computer neu.
  4. Löschen Sie die Programmordner der ArcGIS Enterprise-Komponenten, indem Sie an das unten angegebene Verzeichnis navigieren:
C:\Programme\ArcGIS\<ArcGIS Enterprise-Ordner>
Hinweis: Zu den ArcGIS Enterprise-Ordnern zählen die Ordner "ArcGIS Server", "Portal for ArcGIS" und "ArcGIS Data Store".

Artikel-ID:000025029

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln