ERROR

<service name>Datei kann nicht geöffnet werden <full path name>. Das System kann den angegebenen Pfad nicht finden. Möglicher Grund: Der Server kann nicht auf die Datei zugreifen.

Last Published: April 25, 2020

Fehlermeldung

Bei dem Versuch, vorhandene ArcGIS-Server-Services zu überschreiben und neu zu starten, wird folgender Felder zurückgegeben:

Error:   
Das System kann den angegebenen Pfad nicht finden. Möglicher Grund: Der Server kann nicht auf die Datei zugreifen.

Ursache

Dieses Problem tritt auf, wenn der Computer zwei ArcGIS Server-Verzeichnisse aufweist. Die vorhandenen Serviceordner werden nicht an den neuen Ordner "'arcgisinput" übertragen, der sich im Allgemeinen im folgenden Verzeichnis befindet:

arcgisserver\directories\arcgissystem\arcgisinput

Die Serviceordner speichern alle MXDs, die zum Veröffentlichen der Services verwendet werden. Ohne die MXDs kann der Server die vorhandenen Services nicht überschreiben oder neu starten.

Hinweis:
Dieses Problem tritt nicht bei der Veröffentlichung neuer Services auf.

Lösung oder Problemumgehung

Um das Problem zu beheben, navigieren Sie zum alten Ordner "arcgisinput", kopieren Sie die Ordner der vorhandenen Services, und fügen Sie die Ordner an dem Speicherort des neuen Ordners "arcgisinput" ein. Sobald die Server übertragen wurden, können vorhandene Services überschrieben und neu gestartet werden.

Artikel-ID:000017944

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln