ERROR

Service konnte nicht gestartet werden<serviceName>:<machineName>Es wurde kein Layer bzw. keine Tabelle initialisiert

Last Published: March 18, 2022

Fehlermeldung

Versuche, in ArcGIS Server Manager einen Service zu starten, schlagen fehl, und die folgende Fehlermeldung wird zurückgegeben:

Error: Service <serviceName>:<machineName> konnte nicht gestartet werden. Es wurde kein Layer bzw. keine Tabelle initialisiert.

Ursache

  • Die Datenbank, in der der Service enthalten ist, ist bei ArcGIS Server nicht registriert.
  • Der Data Store, in dem der Service gespeichert ist, wurde nicht validiert.
  • Eine Datei oder Tabelle, die dem Service zugeordnet war, wurde umbenannt. Dadurch wurde der ordnungsgemäß Betrieb des Service verhindert.
  • Mindestens ein Layer im Service enthält eine Tabelle mit mehreren ObjectID-Feldern. Dies geschieht dann, wenn verbundene Attribute, einschließlich der verbundenen ObjectID, in einer neuen Feature-Class gespeichert werden.

Lösung oder Problemumgehung

Registrieren der Datenbank mit dem gespeicherten Service bei ArcGIS Server

Überprüfen Sie, ob die Datenbank mit dem gespeicherten Service bei ArcGIS Server registriert ist. Wenn die Datenbank nicht registriert ist, dann finden Sie die Anweisungen hierzu unter ArcGIS Server: Registrieren von Daten bei ArcGIS Server mit Server Manager.

Data Store überprüfen

Überprüfen Sie, ob der Data Store bei ArcGIS Server validiert wurde. Wenn der Data Store nicht validiert wurde, dann finden Sie die Anweisungen hierzu unter How To: Validate ArcGIS Data Store.

Umbenennen der Datei oder Tabelle in ihren ursprünglichen Namen

Überprüfen Sie, ob der Name der Datei bzw. Tabelle, die auf dem durch ArcGIS Server referenzierten Computer gespeichert ist, konsistent ist, und benennen Sie sie um, wenn dies nicht der Fall ist.

Entfernen aller zusätzlichen ObjectID-Felder aus der Tabelle

Die Anweisungen zum Entfernen eines Feldes aus der Tabelle des Layers in Portal for ArcGIS finden Sie unter Portal for ArcGIS: Hinzufügen oder Löschen eines Feldes.

Artikel-ID:000027384

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln