Fehlermeldung
Versuche, einen Survey aus ArcGIS Survey123 Connect in ArcGIS Online oder Portal for ArcGIS zu veröffentlichen, schlagen fehl, und die folgende Fehlermeldung wird zurückgegeben:
Error: Die Veröffentlichung konnte nicht abgeschlossen werden. Ordner kann nicht erstellt werden. Fehlercode: 400
Ursache
Für dieses Problem sind die folgenden Ursachen möglich:
- Das XLSForm des Survey enthält doppelte Werte in der Spalte des Namensfeldes.
- Der Survey hat denselben Namen wie ein vorhandener Survey-Ordner in ArcGIS Online oder Portal for ArcGIS.
Lösung oder Problemumgehung
Verwenden Sie je nach Ursache des Problems eine der folgenden Optionen:
Ändern der Feldwerte der doppelten Namen in dem XLSForm des Survey- Erstellen Sie eine Kopie des XLSForm des Survey.
- Ändern Sie im XLSForm auf der Registerkarte Survey die doppelten Werte in der Spalte name. In diesem Beispiel werden die Duplikate von "installation_phase", "additional_notes" und "PIA_Phase" in installation_phase_, additional_notes1 und PIA_Phase_ geändert.
- Veröffentlichen Sie den Survey über Survey123 Connect.
Hinweis: Die Werte in der Spalte name müssen für Surveys, die in Portal for ArcGIS veröffentlicht werden, in Kleinschreibung sein.
Umbenennen oder Entfernen des Ordners in ArcGIS Online oder Portal for ArcGIS
- Melden Sie sich bei ArcGIS Online oder Portal for ArcGIS an.
- Navigieren Sie zu Inhalt > Eigene Inhalte.
- Navigieren Sie im linken Bereich unter Ordner zu dem Ordner Survey-<Survey_Name> mit demselben Namen wie dem Survey. In diesem Beispiel ist der Name des Survey "22555_test".
- Zeigen Sie mit der Maus auf den Ordner. Klicken Sie auf Ordner bearbeiten , um den Ordnernamen zu ändern, oder auf Ordner löschen , um den Ordner zu entfernen.
- Veröffentlichen Sie den Survey über Survey123 Connect.