ERROR

Service-Informationen werden abgerufen

Last Published: May 6, 2022

Fehlermeldung

Wenn die ArcGIS Survey123-Website, die mobile ArcGIS Survey123-App oder ArcGIS Survey123 Connect verwendet wird, friert die Anwendung in einigen Fällen ein, wobei die folgende Fehlermeldung zurückgegeben wird:

Error: Service-Informationen werden abgerufen
Die Fehlermeldung

Ursache

Hinweis: Wenn die Ursache nicht sofort offensichtlich ist, finden Sie weitere Anweisungen und Informationen unter ArcGIS Survey123: Protokollieren von Fehlern in einer Konsole.

Dies ist eine generische Fehlermeldung. Für diesen Fehler sind unter anderem folgende Ursachen möglich:

  • Die ArcGIS Survey123-Versionen sind nicht miteinander kompatibel
    In früheren Versionen der mobilen ArcGIS Survey123-App werden die in neueren Versionen erstellten Formulare nicht übermittelt. Dies gilt insbesondere, wenn ein Formular eine Funktionalität nutzt, die erst kürzlich eingeführt wurde.
  • Der Feature-Layer des Survey ist nicht in ArcGIS Online freigegeben
    Wenn ein Survey-Formular ohne den verknüpften gehosteten Feature-Layer in ArcGIS Online freigegeben wird, kann das Formular heruntergeladen, aber nicht übermittelt werden, da der Zugriff auf den Service, der die Daten speichert, nicht möglich ist.
  • Das Survey-Formular wird erneut veröffentlicht
    Bei der erneuten Veröffentlichung eines Survey-Formulars kann ein Konflikt zwischen dem Formular in ArcGIS Survey123 Connect und dem Feature-Service in ArcGIS Online auftreten. Als Folge sind diese nicht synchronisiert, was zu ungültigen Übermittlungen der URL oder Formular-ID führt.
  • Die mobile ArcGIS Survey123-App ist nicht angemeldet
    Auf dem Gerät kann auf das Formular zugegriffen werden, auch wenn die mobile ArcGIS Survey123-App nicht angemeldet ist. Es ist jedoch nicht möglich, das Formular zu übermitteln.
  • Der Inhalt des Survey-Formulars wird geändert
    Änderungen des Survey-Inhalts durch Umbenennen, Löschen oder Verschieben des Survey-Formulars bzw. -Ordners oder Übertragen des Besitzes des Survey-Inhalts auf ein anderes Konto können sich auf die Funktionsfähigkeit der Plattform ArcGIS Survey123 auswirken.
  • Die Internetinformationsdienste (IIS) sind nicht ordnungsgemäß konfiguriert
    Falls die Fehlermeldung mit "Code 0" zurückgegeben wird und die Protokollmeldungen "Requesting featureServiceInfo" und "SSLRead failed: -9842" lauten, wenn Sie mit Portal for ArcGIS arbeiten, kann der Fehler mit der Konfiguration von ArcGIS Web Adaptor (IIS) in Zusammenhang stehen. Dies weist darauf hin, dass der Zertifikateparameter des Clients in IIS mit dem ArcGIS Web Adaptor des Portals auf "Akzeptieren" gesetzt ist.

Lösung oder Problemumgehung

Je nach Fehlerursache stehen verschiedene Workarounds zur Verfügung.

Aktualisieren der ArcGIS Survey123-Version

Aktualisieren Sie die Anwendung ArcGIS Survey123 auf die neueste Version. Zum Herunterladen der neuesten Version von ArcGIS Survey123 rufen Sie ArcGIS Survey123: Ressourcen auf.

Freigeben des Survey und seines verknüpften Feature-Layers in ArcGIS Online und auf der ArcGIS Survey123-Website

Vergewissern Sie sich, dass sowohl das Survey-Formular als auch der verknüpfte Feature-Layer in ArcGIS Online und auf der ArcGIS Survey123-Website freigegeben sind. Weitere Informationen finden Sie unter ArcGIS Survey123: Veröffentlichen Ihres Survey.

Prüfen der Gültigkeit von URL-Übermittlung und Formular-ID

  • Stellen Sie sicher, dass das neueste Survey-Formular heruntergeladen wird und dass sämtliche nach der Veröffentlichung vorgenommenen Konfigurationen erneut angewendet werden, sofern dies erforderlich ist.
  • Vergewissern Sie sich, dass die URL-Übermittlung und die Formular-ID gültig sind. Der Besitzer des Survey muss gewährleisten, dass alle mit dem Besitzerkonto oder Benutzernamen veröffentlichten Surveys für den Download über ArcGIS Survey123 Connect zur Verfügung stehen, sobald die Anmeldung erfolgt ist. Weitere Informationen finden Sie unter ArcGIS Survey123: Einstellungen.

Sicherstellen, dass alle mobilen ArcGIS Survey123-Apps angemeldet sind

Melden Sie sich bei der App an, bevor Sie das Survey-Formular übermitteln. Weitere Informationen finden Sie unter ArcGIS Survey123: Öffnen Ihres Survey.

Sicherstellen, dass alle Survey-Ordnerinhalte vorhanden sind

  • Vergewissern Sie sich, dass die Elemente in einem Zielordner mit demselben Namen abgelegt werden und dass die Freigabeoption sowohl für das Layer- als auch für das Formular-Element beibehalten wird.
Hinweis: Diese Änderungen wirken sich möglicherweise auf andere Benutzer, aber nicht auf den Besitzer aus.
  • Überprüfen Sie den Survey-Ordner im Abschnitt Eigene Inhalte der ArcGIS Online-Organisation. Falls der Ordner vorhanden ist, vergewissern Sie sich, dass alle Layer, Ansichten und Formulare enthalten sind.

Ändern des Zertifikateparamterwertes des Clients in "Ignorieren"

  1. Im Internetinformationsdienste-Manager (IIS) mit ArcGIS Web Adaptor des Portals klicken Sie auf Standardwebsite.
  2. Im Abschnitt IIS wählen Sie SSL-Einstellungen aus.
Das Fenster des Internetinformationsdienste-Managers
  1. Aktivieren Sie im Dialogfeld SSL-Einstellungen das Kontrollkästchen Ignorieren unter Clientzertifikate.
Das Dialogfeld
  1. Klicken Sie im Abschnitt Website verwalten auf Neu starten.
Hinweis: Eine weitere mögliche Ursache besteht darin, dass in ArcGIS Survey123 benutzerdefinierte Rollen festgelegt sind, bei denen einige Berechtigungskonfigurationen zu Fehlern führen können. Stellen Sie zur Behebung dieses Problems sicher, dass Benutzern sowohl Berechtigungen zum Anzeigen als auch zum Aktualisieren zugewiesen sind. Dieser Fehler wurde in ArcGIS Survey123 3.5. behoben.

Artikel-ID:000021434

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden