ERROR

Systemwerkzeuge konnten nicht geladen werden

Last Published: December 29, 2020

Fehlermeldung

Beim Öffnen des Bereichs "Geoverarbeitung" in ArcGIS Pro wird folgende Fehlermeldung angezeigt:

Fehler: Systemwerkzeuge konnten nicht geladen werden.

Gelegentlich folgt dieser Fehlermeldung wie in der folgenden Abbildung eine Traceback-Fehlermeldung von Python, in der ein Modul angegeben ist, das nicht importiert werden kann.

Abbildung der Traceback-Fehlermeldung von Python

Ursache

Die Fehlermeldung bezieht sich auf die Python-Projektumgebung, die von ArcGIS Pro verwendet wird. Die Ursache für diesen Fehler kann ein Konflikt in der Datei "proenv.txt", ein voller Cache oder eine beschädigte Installation von ArcGIS Pro sein.

Lösung oder Problemumgehung

Sie können diesen Fehler beheben, indem Sie eine der folgenden Lösungen verwenden, die Datei "proenv.txt" ändern oder Dateien im Cache löschen. Wenn der Fehler weiterhin auftritt, installieren Sie ArcGIS Pro neu.

Ändern der Datei "proenv.txt", sodass sie der in ArcGIS Pro angegebenen Umgebung entspricht

  1. Navigieren Sie hierzu in ArcGIS Pro zu Einstellungen > Python.
  2. Notieren Sie sich die aktive Projektumgebung. In diesem Beispiel wird in ArcGIS Pro arcgispro-py3 als aktive Umgebung verwendet.
Abbildung mit der Python-Projektumgebung in ArcGIS Pro
  1. Navigieren Sie zum folgenden Speicherort:
C:\Programme\ArcGIS\Pro\bin\Python\Scripts
  1. Öffnen Sie in einem Texteditor die Datei proenv.txt.
  2. Vergewissern Sie sich, dass die aktive Umgebung in ArcGIS Pro der in dieser Textdatei angegebenen Umgebung entspricht. Wenn eine andere Umgebung verwendet wird, ändern Sie die Textdatei so, dass sie der aktiven Umgebung in ArcGIS Pro entspricht.
  3. Speichern und schließen Sie die Datei proenv.txt.
Abbildung mit der Textdatei
  1. Starten Sie ArcGIS Pro neu.

Cache löschen
Löschen Sie alle Cache-Dateien im Ordner AppData, und starten Sie ArcGIS Pro neu.

C:\Users\\AppData\Local\ESRI\Local Caches
Hinweis: Der Ordner AppData ist ausgeblendet. Informationen zum Anzeigen ausgeblendeter Ordner finden Sie unter Microsoft Windows-Support: Anzeigen versteckter Dateien.

Neuinstallation von ArcGIS Pro

Warnung: Mit den folgenden Anweisungen werden Änderungen an entscheidenden Teilen Ihres Betriebssystems vorgenommen. Esri empfiehlt vor dem Durchführen der nächsten Schritte eine Sicherung des Betriebssystems und der Dateien sowie der Registrierung zu erstellen. Für die Ergebnisse bei falschen Modifikationen, die mit diesen Anweisungen vorgenommen werden, kann Esri keine Garantie übernehmen. Lassen Sie Vorsicht walten. Wenden Sie sich bei Bedarf an einen Fachmann für Computersysteme.

Führen Sie eine vollständige Deinstallation durch. Informationen hierzu finden Sie unter Esri Belux: Clean uninstall of ArcGIS Pro. Nachdem Sie eine vollständige Deinstallation durchgeführt haben, installieren Sie ArcGIS Pro neu. Eine Anleitung hierzu finden Sie unter ArcGIS Pro: Installieren von ArcGIS Pro.

Artikel-ID: 000022262

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