ERROR

Fehler beim Erstellen<Feature Name>. Fehler beim Auswerten eines Arcade-Ausdrucks. Regelname:<Rule Name>, Auslösendes Ereignis:<Trigger Type>, Klassenname:<Class Name>, GlobalID: (<Global ID>), Arcade-Fehler: Tabelle nicht gefunden<Table Name>

Last Published: February 11, 2022

Fehlermeldung

Versuche, einen Versorgungsnetz-Layer zu bearbeiten oder zu aktualisieren, schlagen fehl, und die folgende Fehlermeldung wird zurückgegeben:

Error: Fehler beim Erstellen von <Feature-Name>. Fehler beim Auswerten eines Arcade-Ausdrucks. Regelname: <Regelname>, Auslösendes Ereignis: <Trigger-Typ>, Klassenname: <Klassenname>, GlobalID: (<Globale ID>), Arcade-Fehler: Tabelle nicht gefunden <Tablellenname>
Die zurückgegebene Fehlermeldung

Ursache

Die Fehlermeldung wird zurückgegeben, wenn eine Attributregel zu einem Feature-Layer hinzugefügt wird und die Option "Von Anwendungsauswertung ausschließen" nicht aktiviert ist. Mit dieser Option können Änderungen auf Datenbank-Ebene evaluiert werden statt von ArcGIS Pro, bevor die Änderungen an die Quelldatenbank gesendet werden.

Lösung oder Problemumgehung

  1. Öffnen Sie ArcGIS Server Manager. Anweisungen hierzu finden Sie unter ArcGIS Server: Anmelden bei Manager.
  2. Beenden Sie den Utility Network-Service, wenn dieser ausgeführt wird. Eine Anleitung hierzu finden Sie unter ArcGIS Server: Beenden eines Service in Manager.
  3. Öffnen Sie in ArcGIS Pro die Ansicht Attributregeln für die betroffenen Feature-Layer. Anweisungen und weitere Informationen hierzu finden Sie unter ArcGIS Pro: Verwalten von Attributregeln.
  4. Wählen Sie die betroffene Regel aus, um den Bereich Neue Regel zu öffnen.
  5. Aktivieren Sie im Abschnitt für die Ausführung die Option Von Anwendungsauswertung ausschließen.
Der Berechnungsbereich
  1. Klicken Sie auf dem Menüband auf der Registerkarte Attributregeln auf Speichern.
Die Schaltfläche
  1. Wiederholen Sie die Schritte 3 bis 6 für alle betroffenen Feature-Layer.
  2. Starten Sie den Utility Network-Service in ArcGIS Server Manager. Eine Anleitung hierzu finden Sie unter ArcGIS Server: Starten eines Service in Manager.
  3. ArcGIS Pro muss geschlossen und neu gestartet werden, damit die Änderungen wirksam werden.

Artikel-ID:000027192

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden