ERROR

ERROR 000210: Erstellen der Ausgabe nicht möglich.<file path>Fehler beim Ausführen (PivotTable)

Last Published: January 14, 2021

Fehlermeldung

Für möglichst effiziente Datenanalysen können in ArcGIS Pro mit dem Werkzeug Pivot-Tabelle Redundanzen in Datensätzen sowie Eins-zu-Viele-Beziehungen reduziert werden. Manchmal tritt bei der Ausführung des Werkzeugs ein Fehler auf, oder es wird eine der folgenden Fehlermeldungen zurückgegeben:

Error: ERROR 000210: Erstellen der Ausgabe <Dateipfad> nicht möglich. Fehler beim Ausführen (PivotTable).
Abbildung der Meldung zum Fehler

Ursache

Die bekannten Ursachen dieses Fehlers werden im Artikel ArcGIS Pro: 000210: Ausgabe <Wert> kann nicht erstellt werden beschrieben. In diesem Fall führt die Ausführung des Werkzeugs "Pivot-Tabelle" zu diesem Fehler, weil die Spalte, die in der Attributtabelle als Pivot-Feld ausgewählt wurde, NULL-Werte enthält.

Lösung oder Problemumgehung

Verwenden Sie einen der folgenden Workflows, um das Problem zu beheben.

Suchen und Ersetzen von NULL-Werten durch Nullen

Ersetzen Sie mit dem Steuerelement Suchen und Ersetzen von ArcGIS Pro alle NULL-Werte in der Attributtabelle durch Nullen. Eine Anleitung hierzu finden Sie unter ArcGIS Pro: Ersetzen von Werten in einer Tabellenzelle.

  1. Geben Sie unter Suchen <Null> ein. Bei dieser Zeichenfolge muss die Groß-/Kleinschreibung berücksichtigt werden.
  2. Geben Sie unter Ersetzen den Wert 0 ein.
Abbildung mit dem Steuerelement

Ersetzen von NULL-Werten durch Nullen mit dem ArcPy-Modul oder dem Werkzeug "Feld berechnen"

Unter How To: Ersetzen von NULL-Werten durch Nullen in einer Attributtabelle in ArcGIS Pro werden Workflows zum Ersetzen von NULL-Werte durch Nullen mit dem ArcPy-Modul oder dem Werkzeug Feld berechnen beschrieben. Wenn Sie mit dem Werkzeug "Feld berechnen" NULL-Werte durch Nullen ersetzen möchten, verwenden Sie den konditionalen Operator im Python-Parser oder, sofern Sie eine 3D Analyst-Lizenz besitzen, die Funktion Reklassifizieren.

Wenn Sie einen der beiden Workflows ausgeführt haben, müssen Sie die Pivot-Tabelle schließen und wieder öffnen, damit die Daten aktualisiert werden.

Artikel-ID:000024928

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln