ERROR

Tabellen und gespeicherte Prozeduren für Geodatabase konnten nicht erstellt werden. Fehler beim Ausführen (EnableEnterpriseGeodatabase)

Last Published: August 7, 2020

Fehlermeldung

Wenn ArcGIS for Desktop 10.4.1 mit SQL Server 2016 verbunden ist, schlägt das Ausführen des Werkzeugs "Enterprise-Geodatabase aktivieren" für eine neu erstellte Datenbank, die aus einer vorhandenen Enterprise-Geodatabase kopierte Feature-Classes und Tabellen enthält, mit dem folgenden Fehler fehl.

Error: 
Tabellen und gespeicherte Prozeduren für Geodatabase konnten nicht erstellt werden.
Error message
Hinweis:
Das Werkzeug Enterprise Geodatabase aktivieren ist nur mit der Standard- oder Advanced-Lizenz für ArcGIS for Desktop verfügbar. Weitere Informationen finden Sie im Abschnitt mit den Lizenzinformationen für dieses Werkzeug.

Ursache

Die Ursache dieses Fehlers ist, dass mehrere Microsoft-ODBC-Treiber auf dem Computer installiert sind, was manchmal für die Fehlerbehandlung oder zu Testzwecken geschieht. Dies führt zu Konflikten beim Aktualisieren der Geodatabase.

Hinweis:
Weitere Informationen zu Microsoft SQL Server-Datenbankversionen mit in ArcGIS for Desktop 10.4.x unterstützten Treibern finden Sie unter Unterstützte Datenbankversionen.

Lösung oder Problemumgehung

Um das Werkzeug "Enterprise-Geodatabase aktivieren" erfolgreich auszuführen, müssen Sie die SQL Server-Versionen ermitteln, die auf dem Computer installiert sind, und die nicht benötigten ODBC-Treiber deinstallieren.

Hinweis:
Stellen Sie sicher, dass SQL Server Management Studio und alle ArcGIS-Anwendungen geschlossen sind, bevor Sie die SQL Server-Version ermitteln.
  1. Ziehen Sie zum Ermitteln der auf dem Computer verwendeten SQL Server-Version das folgende Dokument zurate: Microsoft Support: So ermitteln Sie die Version, Edition und Updateebene von SQL Server und seinen Komponenten.
  2. Navigieren Sie zu Start > Systemsteuerung > Programme > Programme und Funktionen, und deinstallieren Sie die nicht benötigten Servertreiber.

Artikel-ID: 000017218

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln