ERROR

ArcGIS Pro: Eine Sperre kann nicht angefordert werden

Last Published: April 30, 2024

Fehlermeldung

Beim Versuch, ein Geoverarbeitungswerkzeug in ArcGIS Pro auszuführen, schlägt der Vorgang fehl und gibt die folgende Fehlermeldung zurück:

Error:
Cannot acquire a lock.
Das Fehlerdialogfeld in ArcGIS Pro

Ursache

Eine Schemasperre wird auf eine Geodatabase angewendet und verhindert, dass die Daten gleichzeitig von zwei verschiedenen Werkzeugen oder Anwendungen bearbeitet werden können. Eine Attributtabelle wird z. B. geöffnet, wenn versucht wird, das Werkzeug "Räumliche Verbindung" auszuführen. Die Schemasperre wird auf die Attributtabelle angewendet, sodass Bearbeitungen ausschließlich für sie zulässig sind. Weitere Informationen finden Sie unter ArcGIS Pro: Schemasperren .

Lösung oder Problemumgehung

Identifizieren Sie die aktuell ausgeführten Prozesse im ArcGIS Pro-Projekt, und schließen Sie sie. Im Folgenden finden Sie Situationen, in denen der Fehler auftritt, und wie Sie ihn beheben können:

  • Ein anderes Geoverarbeitungswerkzeug wird ausgeführt, und es wird eine Schemasperre angewendet. Um die Sperre aufzuheben, beenden Sie den aktuellen Prozess, beenden Sie das Werkzeug, indem Sie zum Bereich "Geoverarbeitung" navigieren, und klicken Sie auf Schließen Die Schaltfläche "Schließen" in ArcGIS Pro.
  • Die Attributtabelle eines Layers ist geöffnet. Das Öffnen der Attributtabelle gilt als Zugriff auf die Quelldaten aus einer Geodatabase, daher kann das Schließen der Tabelle die Ausführung anderer Werkzeuge ermöglichen. Um die Attributtabelle zu schließen, wählen Sie die Tabelle aus, und klicken Sie auf Schließen Die Schaltfläche "Schließen" in ArcGIS Pro. Alternativ können Sie Strg + F4 auf der Tastatur drücken, um die Tabelle zu schließen.
  • Ein anderes Gerät oder ein anderer Benutzer greift gleichzeitig auf dieselben Daten zu. Um die Schemasperre aufzuheben, muss das andere Projekt geschlossen werden.
  • Die Daten wurden in einer vorherigen Editiersitzung in ArcGIS Pro gesperrt, und die Sperre wurde beibehalten. Starten Sie das Projekt neu, um die Schemasperre aufzuheben.

Artikel-ID: 000032330

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln