HOW TO

ArcGIS Data Store hat ein Problem bei "db" erkannt.

Last Published: April 19, 2024

Beschreibung

Versuche, einen gehosteten Feature-Layer in ArcGIS Pro auf ArcGIS Server zu veröffentlichen oder einen gehosteten Feature-Layer in Portal for ArcGIS zu öffnen, schlagen fehl, und die folgenden Warn- oder Fehlermeldungen werden in den ArcGIS-Server-Protokollen oder Data-Store-Protokollen zurückgegeben.

Error:
ArcGIS Data Store has detected an issue with 'db'
Error:
ArcGIS Data Store encountered too many problems. Failover may be invoked if standby is configured.
Error:
Data store machine '<machine-name>' has failed

Auch die folgenden Fehler in Postgres-Protokollen (arcgisdatastore\logs\<server-name>\database\<postgresql logs>) können zurückgegeben werden:

Error:
sorry, too many clients already
Error:
remaining connection slots are reserved for non-replication superuser connections
Error:
terminating connection due to administrator command
Error:
the database system is shutting down

Ursache

ArcGIS Data Store ist aus folgenden Gründen nicht verfügbar:

  • Die Portal for ArcGIS-, ArcGIS-Server- und/oder ArcGIS Data Store-Services werden nicht ausgeführt.
  • Der Computer, auf dem ArcGIS Data Store ausgeführt wird, verfügt nicht über ausreichende Ressourcen wie CPU, RAM und/oder Speicher.
  • Der Data Store wurde in ArcGIS Server Manager nicht validiert.
  • Das Domänenkonto, auf dem ArcGIS Server ausgeführt wird, verfügt über keine Berechtigungen für die Verzeichnisse "Data Store", "arcgisdatastore" und "Python27". Dasselbe Domänenkonto muss auch bei der Konfiguration von ArcGIS Server, Portal for ArcGIS und ArcGIS Data Store verwendet werden.

Lösung oder Problemumgehung

Neustarten der ArcGIS Data Store- und ArcGIS-Server-Services

Starten Sie die ArcGIS Data Store-, Portal for ArcGIS- und ArcGIS-Server-Services auf dem Computer neu.

  1. Klicken Sie auf dem Servercomputer mit der rechten Maustaste auf die Taskleiste am unteren Rand des Fensters, und klicken Sie auf Task-Manager.
  2. Klicken Sie im Dialogfeld Task-Manager auf die Registerkarte Dienste.
  3. Klicken Sie mit der rechten Maustaste auf die folgenden Services in der Liste, und starten Sie sie neu:
  • ArcGIS Data Store
  • Portal for ArcGIS
  • ArcGIS Server
Note:
Restart the machine running ArcGIS Data Store if the warnings and errors persist.

Durchführen von Upgrades von CPU, RAM und Speicher des ArcGIS Data Store-Computers (falls erforderlich)

Wenn die CPU-, RAM- oder Festplattenauslastung im Task-Manager nahezu 100 % beträgt, deutet dies darauf hin, dass die Ressourcen unzureichend sind und möglicherweise Upgrades durchgeführt werden müssen. Weitere Informationen finden Sie unter ArcGIS Enterprise: ArcGIS Data Store 11.2 – Systemanforderungen.

Validieren von ArcGIS Data Store in ArcGIS Server Manager

Wenn ArcGIS Data Store nicht validiert wurde, dann finden Sie die Anweisungen hierzu unter How To: Überprüfen von ArcGIS Data Store.

Erteilen der Berechtigung für das ArcGIS-Server-Konto an die Verzeichnisse "Data Store", "arcgisdatastore" und "Python27"

Note:
Completing this workaround may require assistance from the organization's IT department.

Die Standardspeicherorte befinden sich in den folgenden Verzeichnissen:

  • Der Ordner Data Store
C:\Program Files\ArcGIS
  • Der Ordner arcgisdatastore
C:\
  • Der Ordner Python27
C:\Python27

Führen Sie die nachstehenden Schritte aus, um den Ordnern Berechtigungen zuzuweisen.

  1. Navigieren Sie zu den Ordnern Data Store, arcgisdatastore und Python27.
  2. Klicken Sie mit der rechten Maustaste auf den Ordner, und klicken Sie auf Eigenschaften.
  3. Klicken Sie auf die Registerkarte Sicherheit.
  4. Wählen Sie in der Liste Gruppen- oder Benutzernamen das ArcGIS-Server-Konto aus.
  5. Klicken Sie auf Bearbeiten...Das Symbol "Bearbeiten".
  6. Aktivieren Sie das Kontrollkästchen Zulassen, um Vollzugriff zu gewähren.
  7. Klicken Sie auf OK.
  8. Starten Sie den ArcGIS-Server-Service neu. Anweisungen hierzu finden Sie unter ArcGIS Server: Starten und Beenden von Services.

Artikel-ID: 000026836

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln