Fehlermeldung
Bei der Überprüfung mit ArcGIS Data Store tritt ein Fehler auf, und im Serverprotokoll wird die folgende Meldung zu einem SCHWERWIEGENDEN Fehler angezeigt:
Error: ArcGIS Data Store hat einen Replikationsfehler erkannt
Ursache
Dieser Fehler tritt auf, wenn der primäre Data Store und der Standby-Data-Store nicht synchron sind.
Lösung oder Problemumgehung
Führen Sie diese Schritte aus, um dieses Problem beheben:
- Führen Sie die Windows-Eingabeaufforderung als Administrator aus.
- Navigieren Sie mit dem folgenden Befehl zum Ordner der ArcGIS Data Store-Dienstprogramme:
cd <ArcGIS Data Store-Installationsverzeichnis>\DataStore\tools
- Führen Sie das Dienstprogramm "configurebackuplocation" aus, um den Pfad zum Sicherungsordner anzugeben. Weitere Informationen finden Sie unter Portal for ArcGIS: configurebackuplocation.
configurebackuplocation --operation change --store relational|tileCache|spatiotemporal --location <Sicherungsspeicher>
- Wenn Ihnen die Frage Möchten Sie den Vorgang fortsetzen (Ja oder Nein)? gestellt wird, geben Sie Ja ein und drücken die Eingabetaste.
- Führen Sie das Befehlszeilenprogramm "removemachine" aus, um den Standby-Computer mit der folgenden Befehlszeile zu entfernen:
removemachine <Name des Computers> --store {relational | tileCache | spatiotemporal} [--force {true | false}] [--prompt {yes | no}]
- Navigieren Sie auf dem Standby-Computer mit ArcGIS Data Store zu folgendem Verzeichnis:
C:\
- Geben Sie dem Ordner arcgisdatastore den Namen arcgisdatastore_old.
- Konfigurieren Sie den Standby-Data-Store neu. Eine Anleitung hierzu finden Sie unter Portal for ArcGIS: Hinzufügen eines Computers.