Fehlermeldung
Versuche, die Registerkarte "Daten" eines Survey in ArcGIS Survey123 anzuzeigen, schlagen fehl, und es wird folgende Fehlermeldung zurückgegeben:
Error: Beim Laden der Seite ist ein Fehler aufgetreten. Einige Features funktionieren möglicherweise nicht.
Ursache
- Die Abfragefunktion des Feature-Service des Survey ist deaktiviert. In den Einstellungen des gehosteten Feature-Layers ist die Option "Features sind für Editoren nicht sichtbar; dies gilt auch für Features, die sie hinzufügen." aktiviert.
- Der Survey enthält Namensfelder mit reservierten Schlüsselwörtern.
- Es gibt einen vorhandenen Cache im Browser, der die Registerkarte "Daten" am Laden hindert.
Lösung oder Problemumgehung
Je nach Fehlerursache stehen verschiedene Workarounds zur Verfügung.
Die Abfragefunktion des Feature-Service des Survey ist deaktiviert
Aktivieren Sie die Abfragefunktion des Survey in den Einstellungen des gehosteten Feature-Layers.- Melden Sie sich bei ArcGIS Online an.
- Navigieren Sie zu Inhalt > Eigene Inhalte > Survey_<Survey_Name>.
- Wählen Sie im Ordner "Survey" den gehosteten Feature-Layer des Survey aus.
- Klicken Sie in der Elementdetailseite des gehosteten Feature-Layers auf Einstellungen.
- Wählen Sie im Abschnitt Feature-Layer (gehostet) unter Welche Features sind für Editoren sichtbar? die Option Editoren können alle Features anzeigen oder Editoren können nur eigene Features anzeigen (Verfolgung erforderlich) aus, wie in der folgenden Abbildung zu sehen ist.
- Klicken Sie auf Speichern.
Der Survey enthält Namensfelder mit reservierten Schlüsselwörtern
Ändern Sie die reservierten Schlüsselwörter, die als Werte des Feldes name im XLSForm des Survey verwendet werden.- Erstellen Sie eine Kopie des XLSForm des Survey.
- Ändern Sie im XLSForm die reservierten Schlüsselwörter, die als Werte des Feldes name verwendet werden. In diesem Beispiel wurde where in where_ geändert.
- Erstellen Sie in Survey123 Connect einen neuen Survey unter Verwendung der in Schritt 1 erstellten XLSForm-Datei.
- Veröffentlichen Sie den Survey.
Hinweis: Weitere Informationen finden Sie in der Liste Reservierte Schlüsselwörter im Tabellenblatt Types des XLSForm des Survey.
Es gibt einen vorhandenen Cache im Browser, der die Registerkarte "Daten" am Laden hindert- Löschen Sie den Browser-Cache.
- Aktualisieren Sie die ArcGIS Survey123-Website.