ERROR

Auf dem angegebenen Host wurde kein gültiger ArcGIS License Manager für Ihr Lizenzportal gefunden.

Last Published: December 8, 2023

Fehlermeldung

Attempts to connect to ArcGIS License Manager via ArcGIS Pro with a valid license fail, and return the following error message:

Error:   
A valid ArcGIS License Manager for your Licensing Portal could not be found on the specified host. 

Please contact your organization’s License Administrator to ensure that your ArcGIS License Manager is running and accessible.
The error message returned from ArcGIS Pro

Ursache

  • The ArcGIS License Manager is not updated in Portal for ArcGIS. When renewing a license, the ArcGIS License Manager information in Portal for ArcGIS is reverted to the default value if the old keycodes file is removed.
  • An incorrect port is used to connect to ArcGIS License Manager.
  • The machine name is not set using a fully qualified domain name (FQDN). Refer to ArcGIS Enterprise: Domain name service (DNS) and fully qualified domain name (FQDN) requirements for more information.

Lösung oder Problemumgehung

Depending on the cause, use one of the workarounds described below to connect to ArcGIS License Manager via ArcGIS Pro with a valid license.

Update the hostname in ArcGIS License Manager using the Portal Administrator Directory

In the Portal Administrator Directory, the ArcGIS License Manager information is set using the following script:

{
"hostname": "<machine_name>.<domain_name>",
"port": 27000 
}

The image below shows the default hostname of the ArcGIS License Server Administrator machine after updating the license and removing the old keycodes file in Portal for ArcGIS.

The License Manager information after updating via the Portal Administrator Directory

In Portal for ArcGIS, update the hostname of the ArcGIS License Manager information via the Portal Administrator Directory.

  1. Navigate to Home > License > Update License Manager.
  2. Edit the hostname in the License Manager Info text box according to the following script:
{ 
"hostname": "<machine_name>.<domain_name>.com",
"port": 27000 
}
  1. Click Update.

Set the ArcGIS License Manager port in the services.txt file

By default, the service.txt file does not designate a specific port for ArcGIS License Manager to use. Follow the steps below to edit the file and lock ArcGIS License Manager to a specified port.

  1. Navigate to the following directory and open service.txt on the host machine.
C:\Program Files\ArcGIS\LicenseManager\bin
  1. By default, the contents of the file are as follows:
SERVER this_host ANY
VENDOR ARCGIS
Note: 
Create a backup of the service.txt file before editing, as incorrect changes will affect the portal configurations.
  1. Edit the contents of the file as shown below.
SERVER this_host ANY 27000
VENDOR ARCGIS port=27004
Note: 
Any value between 27000 and 27009 can be used for VENDOR ARCGIS PORT.
  1. Click the File tab, click Save in the drop-down menu and close the service.txt file.
  2. Connect to ArcGIS License Manager via ArcGIS Pro.

Set the machine name in the portal-config.properties file

On the ArcGIS Server machine, set the machine name to a FQDN in the portal-config.properties file to accurately identify the machine.

Note: 
Create a backup of the portal-config.properties file before editing, as incorrect changes will affect the portal configurations.
  1. Navigate to the following directory and open portal-config.properties on the host machine.
C:\Program Files\ArcGIS\Portal\framework\etc
  1. Search and edit the property of the file as follows:
portal.machine.name=<FQDN>
  1. Click the File tab, click Save in the drop-down menu and close the portal-config.properties file.
  2. Connect to ArcGIS License Manager via ArcGIS Pro.

Artikel-ID:000027816

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen