ERROR

Es konnte keine Kernlizenz gefunden werden

Last Published: March 23, 2021

Fehlermeldung

Beim Starten von ArcGIS Pro und Anmelden mit Enterprise-Anmeldeinformationen wird folgende Fehlermeldung zurückgegeben:

Error: Es konnte keine Kernlizenz gefunden werden Wählen Sie eine andere Lizenzierungsoption aus, oder wenden Sie sich an den Administrator, um die Lizenzen zu aktualisieren.

Ursache

Dieses Problem kann zwei Ursachen haben:

  • Die JSON-Autorisierungsdatei für Named-User-Lizenzen wurde in ArcGIS Enterprise, nicht jedoch unter ArcGIS License Manager autorisiert.
  • In ArcGIS Pro bleiben alte/beschädigte Lizenzinformationen nach einem Upgrade erhalten und müssen gelöscht werden.

Lösung oder Problemumgehung

Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben:

Problem 1: Die JSON-Autorisierungsdatei für Named-User-Lizenzen wurde in ArcGIS Enterprise, nicht jedoch unter ArcGIS License Manager autorisiert.

  1. Starten Sie ArcGIS License Server Administrator.
  2. Wählen Sie im linken Bereich Autorisierung aus.
  3. Wählen Sie im Dropdown-Menü Version die Option Named User aus, und klicken Sie auf Jetzt autorisieren.
  1. Wählen Sie die Autorisierungsoption Ich habe eine Autorisierungsdatei erhalten und möchte nun den Autorisierungsvorgang abschließen aus.
  2. Klicken Sie auf Durchsuchen, und navigieren Sie zu der mit ArcGIS Enterprise verwendeten JSON-Autorisierungsdatei. Klicken Sie auf Weiter.
  1. Ein Dialogfeld wird angezeigt, das darauf hinweist, dass die Named-User-Lizenzen angewendet wurden. Klicken Sie auf OK.
  1. Klicken Sie auf OK, um ArcGIS License Server Administrator zu schließen.

Problem 2: In ArcGIS Pro bleiben alte/beschädigte Lizenzinformationen nach einem Upgrade erhalten und müssen gelöscht werden.

Warnung: Mit den folgenden Anweisungen werden Änderungen an entscheidenden Teilen Ihres Betriebssystems vorgenommen. Es wird empfohlen, eine Sicherung Ihres Betriebssystems und der Dateien, einschließlich der Registry, anzufertigen, bevor Sie fortfahren. Wenden Sie sich bei Bedarf an einen Fachmann für Computersysteme. Für die Ergebnisse bei falschen Modifikationen, die mit diesen Anweisungen vorgenommen werden, kann Esri keine Garantie übernehmen. Alle Änderungen erfolgen daher auf eigenes Risiko. Durch diesen Vorgang werden die Standardeinstellungen von ArcGIS Pro wiederhergestellt. Dabei gehen sämtliche Anpassungen oder Voreinstellungen (mit Ausnahme von Projektdaten) verloren.
  1. Schließen Sie ArcGIS Pro.
  2. Navigieren Sie zu C:\Benutzer\<lokales Profil>\AppData\Local\ESRI_Licensing
  3. Benennen Sie ESRI_Licensing in ESRI_Licensing_old um.
  4. Öffnen Sie den Registrierungs-Editor, navigieren Sie zum Schlüssel HKEY_CURRENT_USER\Software, und benennen Sie die Struktur ESRI in ESRI_old um. 
  5. Öffnen Sie ArcGIS Pro erneut, und versuchen Sie, eine Named-User-Lizenz zu verwenden. 

Artikel-ID: 000022898

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