ERROR

160333: Die Tabelle wurde nicht gefunden. Bei der Ausführung ist ein Fehler aufgetreten.<tool_name>

Last Published: May 20, 2022

Fehlermeldung

Der Versuch, einer Feature-Class ein neues Feld hinzuzufügen, was auch die Ausführung von Geoverarbeitungswerkzeugen betrifft, mit denen Felder hinzugefügt werden, schlägt fehl, und es wird der folgende Fehler zurückgegeben:

Error: ERROR 160333: Die Tabelle wurde nicht gefunden. Bei der Ausführung ist ein Fehler aufgetreten <Werkzeugname>

Ursache

Die File-Geodatabase, auf die beim Ausführen des Prozesses zugegriffen wurde, wird in einer älteren Version von ArcGIS Desktop erstellt, sodass keine Änderungen in einer neuen Version von ArcGIS Pro möglich sind.

Lösung oder Problemumgehung

Ausführen des Werkzeugs "Geodatabase aktualisieren"

Das Werkzeug "Geodatabase aktualisieren" aktualisiert die File-Geodatabase, sodass sie der aktuellen Version von ArcGIS Pro entspricht, mit der die File-Geodatabase ausgeführt wird. Weitere Informationen finden Sie unter ArcGIS Pro: Geodatabase aktualisieren (Data Management).

Erstellen einer neuen File-Geodatabase und Kopieren der Feature-Datasets und der Feature-Class aus der alten File-Geodatabase, für den Fall, dass das Werkzeug "Geodatabase aktualisieren" nicht ausgeführt werden kann.

  1. Klicken Sie im Bereich Katalog mit der rechten Maustaste auf den ausgewählten Ordner zum Speichern der neuen File-Geodatabase > Neu > File-Geodatabase. Geben Sie einen eindeutigen Namen für die neue File-Geodatabase an.
  2. Suchen Sie die alte File-Geodatabase, und klicken Sie auf das erste Feature-Dataset.
  3. Drücken Sie die Umschalttaste, und wählen Sie das letzte Feature-Dataset aus. Hierdurch werden alle in der alten File-Geodatabase verfügbaren Feature-Datasets ausgewählt.
  4. Klicken Sie mit der rechten Maustaste auf die Auswahl der Feature-Datasets > Kopieren.
  5. Klicken Sie mit der rechten Maustaste auf die neue File-Geodatabase > Einfügen.

Artikel-ID:000027676

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln