ERROR

Es wurde versucht die Verbindung mit einer früheren Version der SQL Server-Clientkommunikationssoftware herzustellen die nicht kompatibel mit dem SQL Server-Datenbankserver ist.

Last Published: November 18, 2021

Fehlermeldung

Beim Herstellen einer Verbindung von ArcGIS Desktop, ArcGIS Pro oder einem anderen ArcGIS-Client mit einer Enterprise-Geodatabase, die im SQL Server erstellt wurde, wird eine der folgenden Fehlermeldungen zurückgegeben:

Verbindungsfehler: Es wurde versucht, die Verbindung mit einer früheren Version der SQL Server-Clientkommunikationssoftware herzustellen, die nicht kompatibel mit dem SQL Server-Datenbankserver ist.
Verbindungsfehler: Datenbankliste kann nicht abgerufen werden. Es ist ein Datenbankverbindungsfehler aufgetreten. Es kann keine Verbindung zum Datenbankserver hergestellt wurden, um die Datenbankliste abzurufen. Überprüfen Sie den Servernamen, Benutzernamen und das Kennwort und versuchen Sie es erneut. Es wurde versucht, eine Verbindung mit einer älteren Version der Kommunikationssoftware des SQL Server-Clients herzustellen, die nicht unterstützt wird.

Ursache

Diese Fehler können auftreten, wenn die Treiber des SQL Server-Clients nicht auf dem PC installiert sind oder die verwendete Treiberversion der Version des SQL Servers, mit dem sich der Benutzer verbindet, nicht unterstützt wird. Die Treiber müssen der SQL Server-Version entsprechen oder neuer als diese sein. Zum Beispiel wird der Microsoft ODBC Treiber 17 für SQL Server von SQL Server 2019 unterstützt, und muss beim Verbinden mit einer SQL Server 2019-Instanz von ArcGIS verwendet werden.

Auch wenn der SQL Server Native Client und die ODBC-Treiber oft abwärtskompatibel zu älteren Versionen sind, sind sie nicht unbedingt aufwärtskompatibel. Es besteht keine Garantie, dass ältere/nicht unterstützte Clients ohne Fehler funktionieren. Beim Durchführen eines Upgrades für die Umgebung, müssen für die Treiber des SQL Server-Clients ebenfalls Upgrades durchgeführt werden. Dadurch wird sichergestellt, dass in ArcGIS neu eingeführte Funktionalitäten unterstützt werden.

Lösung oder Problemumgehung

Überprüfen Sie, dass ein Treiber auf dem Client-PC installiert ist. Wenn er installiert ist, dann stellen Sie sicher, dass er sich mit der gleichen Version wie der SQL Server-Version oder einer neueren Version verbindet.

Die Microsoft-ODBC-Treiber für SQL Server und SQL Server Native Client 2012 stehen bei Microsoft zum Download zur Verfügung. Kopien finden Sie außerdem auch in My Esri. Zum Herunterladen dieser Kopien:

  1. Melden Sie sich bei My Esri an.
  2. Navigieren Sie zu Eigene Organisationen > Downloads > Produkte.
Die Registerkarte
  1. Führen Sie einen Bildlauf bis ArcGIS Enterprise durch, und klicken Sie auf Downloads anzeigen.
  2. Führen Sie einen Bildlauf bis Datenbankunterstützungsdateien durch, und klicken Sie bei der relevanten Version des Microsoft ODBC-Treibers auf Herunterladen.
Laden Sie den aktuellen ODBC-Treiber im Bereich

Die zu installierende Version der Client-Datei hängt von der SQL Server-Version ab. Eine vollständige, aktuelle Liste der unterstützten Datenbankversionen, Betriebssysteme und der zum Verbinden mit dem SQL Server erforderlichen Software finden Sie unter Microsoft SQL Server-Datenbank – Anforderungen für ArcGIS 10.8.x sowie ArcGIS Pro 2.5, 2.6 und 2.7.

Artikel-ID: 000010759

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln