PROBLEM

In Amazon-S3-Bucket gespeicherte Cache-Kacheln nicht gefunden

Last Published: June 1, 2020

Beschreibung

Ein für Karten- und Image-Services erstellter Cache kann in einem S3-Bucket gespeichert werden. Das Speichern von Caches in der Cloud kann hinsichtlich Performance und Wirtschaftlichkeit im Vergleich zum lokalen Speichern großer Caches von Vorteil sein. Amazon EC2 bietet mehrere Instanzgrößen und -optionen für unterschiedlichste Bedürfnisse.

Nach dem Registrieren des Amazon S3-Bucket als Cloud-Speicher und Cache-Verzeichnis bei ArcGIS Server Manager können Sie Caches in den Speicher im S3-Bucket schreiben.

Nach dem Veröffentlichen gecachter Karten- oder Image-Services kann jedoch ein Problem auftreten. Die Cache-Kacheln wurden zwar in den S3-Bucket geschrieben, werden aber beim Anzeigen des Service nicht geladen. Beim Zugriff auf den REST-Endpunkt der Kacheln wird der Fehler "404: Nicht gefunden" zurückgegeben, wie in der folgenden Abbildung dargestellt.

Beim Untersuchen der Caching-Eigenschaften des Service in ArcGIS Server Manager zeigt sich zudem, dass der Kartenservice Dynamisch aus den Daten gezeichnet wird, obwohl beim Veröffentlichen des Service Mit Kacheln aus einem Cache im Service-Editor angegeben wurde.

Ursache

Dazu kommt es, wenn arcgiscache als Ordnername in den Feldern "S3-Bucket-Name" oder "Ordner" angegeben wurde, als der Amazon S3-Bucket als Cloud-Speicher und Cache-Verzeichnis in ArcGIS Server Manager registriert wurde.

Lösung oder Problemumgehung

Beim Registrieren des Amazon S3-Bucket als Cache-Verzeichnis in ArcGIS Server Manager dürfen Sie den Ordnernamen arcgiscache in den Feldern "S3-Bucket-Name" oder "Ordner" nicht verwenden. Registrieren Sie den Amazon S3-Bucket erneut als Cache-Verzeichnis, und verwenden Sie dabei einen anderen Bucket- und Ordnernamen.

Artikel-ID: 000022338

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