BUG

3D Web Styles do not display in the Scene Viewer application in ArcGIS Enterprise 10.9 after installing the Web Styles setup or ArcGIS Enterprise Builder

Last Published: October 2, 2025

Beschreibung

Damit Sie in ArcGIS Enterprise einen vollständigen Satz 3D-Symbolisierung in der Scene Viewer-Anwendung erhalten, müssen Sie das Web-Styles-Setup auf demselben Computer installieren, auf dem auch Portal for ArcGIS ausgeführt wird. (Erfolgt die Installation mit ArcGIS Enterprise Builder, wird das Web-Styles-Setup automatisch installiert.) Nach Installation des Web-Styles-Setups 10.9 oder von ArcGIS Enterprise Builder 10.9 werden einige 3D-Symbole möglicherweise nicht ordnungsgemäß in der Scene Viewer-Anwendung angezeigt.

Ursache

Dieses Problem wird durch einen Tippfehler in einer Datei verursacht, die sich im Portal for ArcGIS-Installationsverzeichnis befindet (BUG-000139952).

Problemumgehung

  1. Navigieren Sie nach der Installation des Web-Styles-Setups 10.9 oder von ArcGIS Enterprise Builder 10.9 zu dem folgenden Verzeichnis im Portal for ArcGIS-Installationsverzeichnis: …\ArcGIS\Portal\framework\template\
    • Standardverzeichnis unter Windows: C:\Programme\ArcGIS\Portal\framework\template
  2. Öffnen Sie in einem Texteditor die Datei portal_install_tokens.txt.
  3. Beachten Sie die letzte Zeile in der Textdatei. Die folgende Abbildung zeigt die betreffende Zeile: Sie lautet:
/filetokens/framework/webapps/arcgis#styleItems//filetokens/framework/webapps/arcgis#styleItems/webstyles_tokens.txt
screenshot1.png
  1. Ändern Sie diese Zeile in:
/filetokens/framework/webapps/arcgis#styleItems/webstyles_tokens.txt
Die folgende Abbildung zeigt die geänderte Zeile: screenshot2.png
  1. Speichern Sie die Datei portal_install_tokens.txt.
  2. Starten Sie den Portal for ArcGIS-System-Service neu.

Artikel-ID: 000025644

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln