PROBLEM

ArcGIS StoryMaps reagiert nicht mehr und lädt nicht, wenn es über das App-Startprogramm für Portal for ArcGIS geöffnet wird

Last Published: March 24, 2021

Beschreibung

Dieses Problem kann nach einem Upgrade von ArcGIS Enterprise 10.6.1 auf 10.8.1 auftreten.ArcGIS StoryMaps reagiert nicht mehr und lädt nicht, wenn es über das App-Startprogramm für Portal for ArcGIS geöffnet wird.
 

Ursache

Verglichen mit einer Arbeitsumgebung enthalten einige Zeilen der StoryMap-Datei "config.json" zusätzliche Schrägstriche (/).

Diese Datei befindet sich unter:

C:\Program Files\ArcGIS\Portal\apps\storymaps\static\config.json

Lösung oder Problemumgehung

  1. Erstellen Sie einen Snapshot und aktualisieren Sie die Datei, indem Sie die zusätzlichen Schrägstriche aus drei Zeilen der config-Datei der Story Map entfernen, siehe hierzu die folgende Abbildung.
  2. Navigieren Sie zu: C:\Program Files\ArcGIS\Portal\apps\storymaps\static\config.json, und öffnen Sie die Datei in einem Text-Editor wie Notepad++.

Datei

  1. In der obigen Abbildung der config-Datei sehen Sie in den Zeilen 26, 27 und 28 je einen zusätzlichen Schrägstrich in der URL (/) hinter portal (hervorgehoben). Diese müssen gelöscht werden.
    Zeile 26 sieht beispielsweise folgendermaßen aus:
"ARSGIS_JS_API_URL": "https://<domain>/portal//jsapi/jsapi4/",
  1. Löschen Sie die zusätzlichen Schrägstriche, und speichern Sie die config-Datei.
  2. Sofern es keine anderen Probleme mit der Bereitstellung gibt, dürfte sich ArcGIS StoryMaps sich jetzt über das App-Startprogramm öffnen lassen.

Artikel-ID: 000024953

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln