BUG

In ArcGIS Engine-Anwendungen schlägt die Autorisierung mit einer ASR-Lizenz (*.asr) fehl

Last Published: April 25, 2020

Beschreibung

In älteren Kopien von ArcGIS Engine tritt ein Bug auf, wenn ASR-Lizenzdateien (*.asr) autorisiert werden, in denen als Ablaufdatum "Permanent" angegeben ist. Dieses Problem betrifft ArcGIS Engine 10.0 (final) bis 10.0 SP5. Version 10.1 (final) und höher sind nicht betroffen. Anwendungen von ArcGIS-Versionen mit einer Secure License File (*.eslf) oder einem anderen Typ von Autorisierung sind ebenfalls nicht betroffen.

Bereitgestellte Anwendungen, die bereits mit einer älteren ASR-Datei autorisiert wurden, werden weiterhin ausgeführt. Neu bereitgestellte Anwendungen, in denen die älteren ASR-Dateien verwendet werden, können jedoch bei der Autorisierung fehlschlagen, und jede vor dem 1. Februar 2018 empfangene ASR-Datei (*.asr) kann einen Fehler verursachen.

Hinweis:
ASR-Lizenzen sind keine Standardlizenzdateien, da sie als Autorisierung verwendet werden, die in die mit ArcGIS Engine erstellten OEM-Anwendungen (Original Equipment Manufacturer) eingebettet sind.

Ursache

Die Berechnung des Datums "Permanent" (Datum und Uhrzeit) anhand der ASR-Datei verursacht das Fehlschlagen des Autorisierungsvorgangs. Dieser Bug ist im FlexNet Publisher-Drittanbietercode vorhanden, der in diesen älteren ArcGIS-Versionen enthalten war.

Problemumgehung

Da die betroffenen Versionen von FlexNet Publisher nicht mehr von Flexera unterstützt werden, ist eine neue ASR-Datei erforderlich. Durch das Ersetzen der alten ASR-Datei durch eine neue ASR-Datei in der Anwendung wird das Problem behoben.

In den neuen Dateien wird ein Ablaufdatum angezeigt, das mindestens 20 Jahre in der Zukunft liegt. Wenn nach dem Anwenden der neuen Datei das Ablaufdatum der Lizenzdatei mithilfe von ArcGIS Administrator angezeigt wird, wird stattPermanent ein Datum angezeigt (z. B. 7-feb-2040).

Falls Sie sich nicht sicher sind, ob Sie von diesem Problem betroffen sind, oder wenn Sie Fragen zur Verwendung einer neuen ASR-Datei haben, wenden Sie sich an den technischen Support von Esri.

Um eine neue ASR-Datei anzufordern, wenden Sie sich an einen Ansprechpartner beim Esri Customer Service.

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