BUG

Nach dem Upgrade schlägt das Registrieren einiger Datenspeicher mit dem Fehler PARENT_NOT_REGISTERED in ArcGIS Server Manager 10.5 fehl

Last Published: April 25, 2020

Beschreibung

Nach dem Upgrade einer älteren Version von ArcGIS Server auf ArcGIS Server 10.5 kann ArcGIS Server Manager die Big-Data-Dateifreigabe, den Raster-Speicher oder den Cloud-Speicher nicht als Datenspeicher registrieren. Dabei wird die folgende Fehlermeldung zurückgegeben.

Error: 
PARENT_NOT_REGISTERED

Ursache

Nach dem Upgrade einer älteren Version von ArcGIS Server auf 10.5 werden die bei ArcGIS Enterprise 10.5 unterstützten neuen Datenelemente (wie zum Beispiel die Big-Data-Dateifreigabe, der Raster-Speicher oder der Cloud-Speicher) bei ArcGIS Server nicht registriert. Deshalb können Benutzer eine Big-Data-Dateifreigabe, die durch den GeoAnalytics-Server verwendet werden soll, oder einen Raster-Speicher, der durch den Raster-Analyse-Server verwendet werden soll, nicht registrieren. Die Benutzer können auch keinen Cloud-Speicher registrieren, wenn GIS-Ressourcen und -Daten in Amazon Web Services oder Microsoft Azure gespeichert sind.

Problemumgehung

Registrieren Sie die Big-Data-Dateifreigabe, den Raster-Speicher und den Cloud-Speicher als Datenelemente im ArcGIS-Server-Administratorverzeichnis.
  1. Melden Sie sich beim ArcGIS-Server-Administratorverzeichnis mit dem Administratorkonto an.
  2. Navigieren Sie zu data und wählen Sie registerItem aus.
  3. Kopieren Sie den folgenden Inhalt in das Feld neben Item, um den Cloud-Speicher als Datenelement hinzuzufügen:
{
"path": "/cloudStores",
"type": "datadir"
}
  1. Klicken Sie auf Element registrieren, um das Element bei ArcGIS Server zu registrieren.
  2. Wiederholen Sie die Schritte 3 und 4 für den Raster-Speicher und die Big-Data-Dateifreigabe.
{
"path": "/rasterStores",
"type": "datadir"
}
{
"path": "/bigDataFileShares",
"type": "datadir"
}
  1. Registrieren Sie die Big-Data-Dateifreigabe, den Raster-Speicher und den Cloud-Speicher als Datenspeicher in ArcGIS Server Manager.

Artikel-ID: 000015216

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln