PROBLEM

Eine in einer PostgreSQL-Datenbank erstellte Tabelle wird in ArcGIS Pro nicht angezeigt

Last Published: March 26, 2024

Beschreibung

In PostgreSQL wird eine Tabelle mit einem eindeutigen ID-Feld erstellt. Die Tabelle wird in einem Schema gespeichert, das einem angemeldeten Benutzer mit demselben Namen wie das Schema gehört. In pgAdmin wird die Tabelle angezeigt und kann abgefragt werden. In dem Beispiel, das in der Abbildung von pgAdmin unten gezeigt wird, heißt diese Tabelle "TESTTABLE".

2024-03-08_11-12-22.png

In ArcGIS Pro wird die neue Tabelle jedoch nicht angezeigt, selbst wenn Sie die Verbindung zur PostgreSQL-Datenbank als Besitzer der Tabelle herstellen, wie in der nächsten Abbildung dargestellt.

2024-03-08_11-24-40.png

Ursache

Der Tabellenname besteht aus Großbuchstaben. In PostgreSQL erfordert die Verwendung von Großbuchstaben oder einer Mischung aus Groß- und Kleinbuchstaben in Tabellennamen, dass alle Abfragen in doppelten Anführungszeichen erstellt werden. Dies wird in ArcGIS for PostgreSQL nicht unterstützt. Beim Herstellen einer Verbindung mit einer PostgreSQL-Datenbank aus ArcGIS Pro werden Tabellen, deren Name aus Großbuchstaben oder einer Mischung aus Groß- und Kleinbuchstaben besteht, nicht angezeigt.

Lösung oder Problemumgehung

Ändern Sie den Tabellennamen in Kleinbuchstaben.

2024-03-08_11-30-20.png

 

2024-03-08_11-30-47.png

Artikel-ID: 000032184

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln