PROBLEM

Address locators built at ArcGIS for Desktop 10.4 or earlier and stored in geodatabases do not display as inputs to tools and not are visible in ArcCatalog

Last Published: April 25, 2020

Description

ArcGIS 10.4 was the last release to support storing address locators in a geodatabase. This article discusses what to do if you have upgraded to ArcGIS Desktop 10.5 or ArcgGIS Pro 1.4 and you have locators stored in geodatabases.

Cause

Address locators stored in geodatabases are no longer supported as specified in the deprecation plan for ArcGIS Desktop 10.4/10.4.1. This means that prior to 10.5 address locators were visible inside of the geodatabase, but after installing 10.5 locators are no longer visible when viewing the contents of the geodatabase. In ArcGIS Pro 1.4 as well, address locators can no longer be seen inside of geodatabases to be able to use them as inputs into tools.

Solution or Workaround

Customers must copy or move their address locators from geodatabases into file folders before installing 10.5, using copy/paste in ArcCatalog or running the Data Management Copy tool. If the locators are not movedĀ before installing 10.5, a previous version can be installed to move the locators out of the geodatabase andĀ into a file folder. If it is not possible to revert back to a previous version, new address locators must be created using the 10.5 style.

Article ID: 000014485

Software:
  • ArcMap
  • ArcGIS Pro 1 x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options