PROBLEM

Report is not generated after selecting a report format

Last Published: April 26, 2020

Description

After clicking 'View in' and selecting a report format, a spinning cursor appears on the map and the report is not generated. In the network traffic, an HTTP 404 (404.13, 404.14, or 404.15) error is returned on requests to the Esri Maps for IBM Cognos proxy. This issue is observed when using Mozilla Firefox or Google Chrome in situations where Internet Information Services (IIS) is being used as the web server for the Esri Maps for IBM Cognos (EM4C) Gateway.

Cause

This issue is encountered when the content length, URL length, and/or the query string length exceed the maximum lengths specified in IIS.

Solution or Workaround

To address this issue, the relevant IIS setting must be changed to allow longer content, URL, or query string lengths.

Note:
The following steps are for IIS 7, 7.5, 8, or 8.5, and require the IIS Request Filtering filter to be installed.

  1. Open IIS Manager.
  2. In the Connections pane, select the 'cgi-bin' application within the 'em4c' virtual directory.
  3. In the Home pane, double-click 'Request Filtering', located in the 'IIS' section.
  4. In the Actions pane on the right, click 'Edit Feature Settings...'.
  5. Increase the maximum length of the following setting(s) as necessary:
    • For HTTP 404.13 errors, change the 'Maximum allowed content length (Bytes)'.
    • For HTTP 404.14 errors, change the 'Maximum URL length (Bytes)'.
    • For HTTP 404.15 errors, change the 'Maximum query string (Bytes)'.
  6. Click OK.

Article ID: 000012227

Software:
  • ArcGIS Maps for IBM Cognos 6 0

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