How To: Connect to an Excel spreadsheet in ArcCatalog


Instructions provided describe how to connect to an Excel spreadsheet from ArcGIS. ArcGIS can retrieve data from Microsoft Excel 5.0, 7.0, 97, 2000, 2003, or 2007 files.


There are three procedures to create an OLE DB connection to an Excel spreadsheet.

A. Create an Open Database Connectivity (ODBC) data source.

1. Open the ODBC Data Source Administrator.

▪ In Windows NT: Click Start > Settings > Control Panel and double-click ODBC Data Sources.

▪ In Windows 2000 and XP: Click Start > Control Panel > Administrative Tools > Data Sources (ODBC).

2. Select the User DSN tab and click Add.

3. Select a Microsoft Excel Driver.

▪ For Excel 2003 and earlier, select Microsoft Excel Driver (*.xls).

▪ For Excel 2007, select Microsoft Excel Driver (*.xls, *.xslx, *.xslm, *.xslb).

4. Click Finish.

5. In the ODBC Microsoft Excel Setup dialog box, type a Data Source Name, such as test_xls, and a description for the data source.

6. Select the Excel version from the drop-down list, and click the Select Workbook button.

7. Navigate to the Excel data file.

8. Click OK three times to exit all the dialog boxes and finish creating the new data source.

B. Place the data in the OLE DB table format.

1. Open the .xls file in Microsoft Excel.

2. Select the data (cells) you want to display in ArcInfo.

3. Create a table name. This name appears in the tables list when the OLE DB connection is expanded in ArcCatalog or ArcMap.

▪ In Excel 2003 and earlier versions: Click Insert > Name > Define and type in a name for the selected cells.

▪ In Excel 2007: Click Insert > Table. In the Create Table dialog, verify the selected cells and click OK. Under Table Name, type a name for the table.

4. Save the file and quit Excel.

C. Connect to the Excel file from ArcCatalog.

1. Start ArcCatalog.

2. Expand Database Connections.

3. Double-click Add OLE DB Connection.

4. In the Data Link Properties dialog box, select Microsoft OLE DB Provider for ODBC Drivers, and click Next.

5. On the Connection tab, select Use data source name.

6. Select your Excel file from the drop-down list. Use the Refresh button if necessary.

7. Click the Test Connection button to verify the connection works. A message box should confirm the connection has succeeded.

8. Click OK to finish the process.

9. In ArcCatalog, type a name for the connection.

ArcCatalog sets the column headings based on the values contained in the first row of the Excel spreadsheet. Make sure the first row of the spreadsheet contains column headings.

Related Information