Customer Service | Training | Contact Us
Welcome!
Login
Search Options   products areas display

Which products should be considered?

All Products

ArcCAD
ArcEditor
ArcExplorer
ArcGIS Engine
ArcGIS Explorer
ArcGIS Image Server
ArcGIS Mobile
ArcGIS Server
ArcIMS
ArcInfo Desktop
ArcInfo Workstation
ArcLogistics Route
ArcPad
ArcPad Application Builder
ArcReader
ArcSDE
ArcView
ArcView 3.x
ArcWeb Services APIs
ArcWeb Toolbar for ArcGIS
Atlas GIS
BusinessMap
BusinessMap Pro
GIS Portal Toolkit
Job Tracking for ArcGIS
Maplex
MapObjects -- Java
MapObjects -- Windows
MapObjects IMS
MapObjects LT
MapStudio
Military Overlay Editor
NetEngine
PC ARC/INFO & DAK
PLTS
RouteMap
RouteMap IMS
SDE
Tracking Server

    Remember these settings for each visit More info
You are here:

Technical Article   Error:  Error 1935

Article ID: 28553
Software:  ArcGIS - ArcEditor 9.0, 9.1, 9.2, 9.3 ArcGIS - ArcInfo 9.0, 9.1, 9.2, 9.3 ArcGIS - ArcView 9.0, 9.1, 9.2, 9.3 ArcGIS Engine Developer Kit 9.0 ArcGIS Server 9.0 ArcIMS 9.0, 9.1, 9.2, 9.3 ArcReader 9.0 ArcSDE 9.0, 9.1, 9.2, 9.3
Platforms:  Windows NT 4.0, 2000, XP, 2003Server

Error Message

When installing ArcGIS Server, ArcGIS Desktop, including ArcView, ArcEditor, ArcInfo; or ArcIMS, the following error may occur:

"Error 1935: An error occured during the installation of assembly component {303994BA-6487-47AE-AF1D-7AF6088EEBDB}. HRESULT: -2147024894."

After clicking 'OK' the installation rolls back.

Cause

This error occurs during the system update stage of the installation when the Microsoft XML Parser 4 installs. The same error should occur when trying to install the Microsoft XML Parser 4.0 by itself.

The cause can vary, but frequently may be caused by system files being used by another product.

Solution or Workaround

Follow the steps below to work around this error.

  1. Stop as many programs as possible. Some programs may be running in the background, such as adware or spyware. An example of such software is Adwatch. If possible, remove any adware from the machine.
  2. Stop as many Windows services as possible by navigating to Control Panel > Administrative Tools > Services.
  3. Verify that Internet Explorer 6.0 is installed. Verify that all Microsoft service packs and updates have been installed.
  4. Install Microsoft XML 4.0 SP2 before continuing. Download the link in the Related Information section below.

     The previous XML parser may need to be uninstalled before installing XML 4.0 SP2.

  5. Install the ESRI software again if Step 4 was successful.

Related Information


Created: 1/19/2005
Last Modified: 9/17/2008

This website's graphical display is now viewable only with W3C standards-compliant browsers, but the content is accessible to all browsers and Internet devices. View our supported browser matrix for more information on our website display.