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Technical Article   Error:  The System Clock has been set back to the past. This is not allowed!

Article ID: 24575
Software:  ArcGIS - ArcEditor 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2 ArcGIS - ArcInfo 8.0.1, 8.0.2, 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2 ArcGIS - ArcView 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2 ArcInfo Workstation 7.2.1, 8.0.1, 8.0.2, 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2, 9.3
Platforms:  Windows NT 4.0, 2000, XP

Error Message

Starting an ESRI software product may return the following error:

"The System Clock has been set back to the past. This is not allowed!"

Cause

Any action that puts future-dated files on the license manager server results in this error message. Setting the system clock to the past, setting the clock ahead and then back to the present, or getting future-dated files from another source are all examples of such an action. Having future-dated files on a machine with ArcView and ArcEditor Single Use also causes the same error.

Solution or Workaround

Follow the steps below.

  1. Verify that the date and time on the system are correct. Also verify that AM or PM is set properly. -show me-

    Select Start > Settings > Control Panel > Date/Time.
    [O-Image] System Clock
  2. Verify the time zone is correct. -show me-

    Windows NT and 2000:
    1. Select Start > Settings > Control Panel > Date/Time.
    2. Select the Time Zone tab.

    Windows XP:
    1. Select Start > Control Panel > Date and Time.
    2. Select the Time Zone tab.
  3. Reboot the computer and start ArcMap. If problem persists, move to Step 4.
  4. Verify that there are no hidden files and folders. -show me-

    Windows NT:
    1. Right click the My Computer icon on the desktop and select Explore.
    2. Select View > Options.
    3. On the View tab verify that:
    · "Show all files" is selected.
    · "Hide files of these types" is unselected.
    · "Hide file extensions for known file types" is unselected.
    4. Click Apply and OK.

    Windows 2000:
    1. Right click the My Computer icon on the desktop and select Explore.
    2. Select Tools > Folder Options.
    3. On the View tab verify that:
    · "Show hidden files and folders" is selected.
    · "Hide file extensions for known file types" is unchecked.
    · "Hide protected operating system files (Recommended)" is unchecked.
    4. Click Yes when prompted.
    5. Click Apply and OK.

    Windows XP:
    1. Right click the My Computer icon on the desktop and select Explore.
    2. Select Tools > Folder Options.
    3. On the View tab verify that:
    · "Show hidden files and folders" is selected.
    · "Hide file extensions for known file types" is unchecked.
    · "Hide protected operating system files (Recommended)" is unchecked.
    4. Click Yes when prompted.
    5. Click Apply and OK.
  5. Search the computer's hard drive for files with future file dates. -show me-

    Windows NT:
    1. Select Start > Find > Files or Folders.
    2. Select the Date Modified tab and choose Select between.
    3. Type in tomorrow's date and 12/31/2099.
    4. Click Find Now.

    Windows 2000:
    1. Select Start > Search > For Files or Folders.
    2. Select Search Options.
    3. Check the Date box and select Between.
    4. Type in tomorrow's date and 12/31/2098.
    5. Click Search Now.

    Windows XP:
    1. Select Start > Search.
    2. Choose All Files and Folders.
    3. Select Search Options.
    4. Check 'When was it modified?' and select Specify Dates.
    5. Type in tomorrow's date and 12/31/2098.
    6. Click Search Now.

  6.  WARNING: The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

    ESRI cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.

    Remove all files and folders whose time/date stamp is greater than 4 hours ahead of the current system time and date. This may require moving them onto another workstation, reloading applications, or in the case of system files, it may be necessary to reinstall the operating system.

     Though alternatives may be available, ESRI Technical Support cannot provide or support the use of them. If there are further questions regarding the information in this article contact ESRI Technical Support, otherwise direct all other inquiries to an ESRI regional representative.


Created: 2/25/2003
Last Modified: 9/11/2008

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