Customer Service | Training | Contact Us
Welcome!
Login
Search Options   products areas display

Which products should be considered?

All Products

ArcCAD
ArcEditor
ArcExplorer
ArcGIS Engine
ArcGIS Explorer
ArcGIS Image Server
ArcGIS Mobile
ArcGIS Server
ArcIMS
ArcInfo Desktop
ArcInfo Workstation
ArcLogistics Route
ArcPad
ArcPad Application Builder
ArcReader
ArcSDE
ArcView
ArcView 3.x
ArcWeb Services APIs
ArcWeb Toolbar for ArcGIS
Atlas GIS
BusinessMap
BusinessMap Pro
GIS Portal Toolkit
Job Tracking for ArcGIS
Maplex
MapObjects -- Java
MapObjects -- Windows
MapObjects IMS
MapObjects LT
MapStudio
Military Overlay Editor
NetEngine
PC ARC/INFO & DAK
PLTS
RouteMap
RouteMap IMS
SDE
Tracking Server

    Remember these settings for each visit More info
You are here:

Technical Article   Error:  Warning: The (extension) license has expired

Article ID: 21140
Software:  ArcGIS - ArcEditor 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2, 9.3 ArcGIS - ArcInfo 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2, 9.3 ArcGIS - ArcView 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2, 9.3
Platforms:  Windows NT 4.0, 2000, XP

Error Message

When starting ArcGIS, an error message is displayed noting that one or more licenses have expired. For example:

Warning: The ArcPress (ArcPress) license has expired.

Warning: The Geostatistical Analyst (GeoStats) license has expired.
Warning: The 3D Analyst (TIN) license has expired.
Warning: The Spatial Analyst (Grid) license has expired.
Warning: The StreetMap USA (StreetMap) license has expired.

Cause

The license or licenses listed in the error message have expired and may block the use of existing, non-expired licenses from working properly.

Solution or Workaround

The best solution is to delete the expired licenses. The expired license messages can also just be suppressed, however, expired licenses can causes problems for valid licenses.

  • Remove the expired license files
    1. On the computer where the license manager is installed, start Windows Explorer and navigate to the license manager install location. By default, this is located at C:\Program Files\ESRI\License or \ESRI\License\ArcGIS9x.
    2. Delete any and all expired licenses .LIC files
    3. Restart the license service in LM Tools or reboot the computer.

     Don't delete any license files with an expiration date of 01-jan-00; this indicates the license has no expiration date.

  • Suppress the license expiration warnings.
    See the link in the Related Information section for information on this procedure.

Related Information


Created: 12/7/2001
Last Modified: 9/10/2008

This website's graphical display is now viewable only with W3C standards-compliant browsers, but the content is accessible to all browsers and Internet devices. View our supported browser matrix for more information on our website display.