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Technical Article   FAQ:  What are the limitations and issues with ArcGIS 9.x products under Windows XP Service Pack 2 and Service Pack 3?

Article ID: 28655
Software:  ArcGIS - ArcEditor 9.1, 9.2, 9.3 ArcGIS - ArcInfo 9.1, 9.2, 9.3 ArcGIS - ArcView 9.1, 9.2, 9.3 ArcGIS Engine Developer Kit 9.1, 9.2, 9.3 ArcGIS Engine Runtime 9.1, 9.2, 9.3 ArcGIS Server 9.1, 9.2, 9.3 ArcIMS 9.1, 9.2, 9.3 ArcInfo Workstation 9.1, 9.2, 9.3 ArcReader 9.1, 9.2, 9.3 ArcSDE 9.1, 9.2, 9.3
Platforms:  Windows XP

Question

What are the limitations and issues with ArcGIS 9.x products under Windows XP Service Pack 2 and Service Pack 3?

Answer

The ArcGIS 9.x products: ArcView, ArcEditor, ArcInfo Desktop, ArcInfo Workstation, ArcIMS, and ArcGIS Server under Windows XP Service Pack 2 and Service Pack 3 (SP2 & SP3) are certified with limitations. Several of the known limitations can be prevented with the workarounds listed below or can be corrected if the errors are encountered.

ArcGIS Products General

License Manager Issue

Microsoft Internet Connection Firewall (ICF) is enabled by default, in the Windows XP Service Pack release. ICF restricts access to ports necessary for communication between ArcGIS 9.x and the license manager.

Workaround: Instructions provided in the ESRI Knowledge Base article 26134 detail the steps to reopen the correct ports and allow ArcGIS 8.x and 9.x to communicate with the license manager. -show me-

Summary
Instructions provided describe how to configure Windows XP's Internet Connection Firewall to work with the license manager. With the release of Windows XP Service Pack 2 (SP2), Microsoft has enabled its Internet Connection Firewall (ICF) by default. ICF restricts access to ports necessary for communication between ArcGIS and the license manager. The instructions provided below detail the steps to reopen the correct ports and allow ArcGIS to communicate with the license manager.

An alternative to this procedure would be to disable the ICF completely. Consult IT personnel before doing so.
Procedure
Machines running ArcGIS and Windows XP SP2 with ICF enabled, including the License Manager server, must run these steps while logged into the computer with administrative privileges. If the user account does not have administrative rights, contact a system administrator.

This article requires use of the Classic View in the Windows XP Control Panel.

  1. On the License Manager server, lock the ESRI (ArcGIS 8.x) or ArcGIS (ArcGIS 9.0) vendor daemon to a static port.
    -show me-

     The port specified in this step must be different than the port specified in step 6 below.

  2. Click Start > Control Panel > Network Connections on all machines with Windows XP Service Pack 2.

     These steps require the use of the Control Panel Classic View.

  3. Click Change Windows Firewall Settings in the left panel.
  4. Click the Exceptions tab.
  5. Click Add Port...
  6. Enter 'lmgrd' in the Name field. In the Port Number field enter the port number specified in the license file.
    -show me-
    Protocol should be set to TCP. Click OK.
  7. Click Add Port... again in the Exceptions dialog box and follow the same procedure used in the previous step, entering 'ArcGIS' at version 9.x or 'ESRI' at version 8.x in the Name field, and the number added to the license file in steps 1-7 as the Port Number (for example, 1234).
  8. Click OK to close and enable the Internet Connection Firewall.


The license Manager Issue affects both 8.x and 9.x license managers; therefore, all license managed products are affected. These products include:
-ArcGIS Desktop 8.x and 9.x
-Concurrent Use ArcInfo Workstation 8.x and 9.x
-ArcSDE 8.x
-ArcIMS ArcMap Server 4.x

ArcGIS Desktop: ArcInfo, ArcEditor, ArcView

Other miscellaneous problems were reported using ArcGIS 9.x Desktop products with these Windows XP Service Packs. These issues are being researched as they are reported. The majority of the issues reported could not be reproduced in-house. Some random ArcGIS 9.x problems seem to relate to incomplete or corrupt installs of Windows or the service packs. In these rare cases, repairing the system files solved the issues.

Script tools based on AMLs do not run after installing Windows XP SP2 or SP3.

This problem persists even after running the RunAMLasExecutable.reg. One of the following scenarios occurs when an AML script is run:

- An empty DOS window appears, but nothing happens and the script does not run.

- The progress dialog box indicates that the script is running, but nothing happens and the script does not run.

To fix these problems, complete the following steps:

1. Find the RegisterAMLasExecutable.reg file, typically found at C:\Program Files\ArcGIS\ArcToolbox\Scripts.

2. Right-click and edit the file.

3. In the line that follows, replace arc.exe with the full path to arc.exe:
@="arc.exe \"&run\" %0 %*"

For example, if the path to arc.exe is C:\arcgis\arcexe9x\bin\arc.exe, the new line looks as follows:
@="\"C:\\arcgis\\arcexe9x\\bin\\arc.exe\" \"&run\" %0 %*"

Notice that the \ is an escape character, which must be inserted before all quotation marks (") and slashes (\).

Once the changes above have been made, double-click the file. At the prompt that asks if the information should be added to the registry, click OK. Once informed that the information was successfully added; Click OK.

AML scripts should now run correctly.


ArcGIS Server

When installing Windows XP SP2 or SP3, Microsoft installs and enables a firewall called Windows Firewall. The default settings in the firewall cause ArcGIS 9.x Server to block all incoming connections. To correct this, add exceptions in the Windows Firewall. For instructions on how to do this, refer to the following KB article:

How-To: Configure Windows XP SP2 or SP3 Firewall to work with ArcGIS Server, ESRI Knowledge Base article 27798. -show me-

Summary
Instructions provided describe how to configure Windows XP SP2 Firewall to work with ArcGIS Server. Windows XP Service Pack 2 must be installed to complete the procedure below, which outlines the steps required to configure Windows Firewall for ArcGIS Server.
Procedure
When upgrading Windows XP with Service Pack 2, a firewall titled 'Windows Firewall' is installed and enabled. The default settings for the firewall cause Windows XP to block all incoming connections for ArcGIS Server. To work around this, create exceptions for port 80, port 135, ArcSOM.exe and ArcSOC.exe in the Windows Firewall settings.

  1. Navigate to Windows Firewall.

    Start > Settings > Control Panel > Windows Firewall

     The firewall is 'On' by default, the 'Recommended' setting.

  2. Click on the Exceptions tab.
  3. Click 'Add Port'.
  4. Add the following information:

    Name: Web Port (http)
    Port Number: 80
    Type: TCP

    Click OK.
  5. To add port 135, click 'Add Port'.
  6. Add the following information:

    Name: DCOM (ArcGIS Server)
    Port Number: 135
    Type: TCP

    Click OK.
  7. Click 'Add Program' to add an exception for ArcSOM.exe.
  8. Click 'Browse' and navigate to:
    <ArcGIS Install Directory>\bin\ArcSOM.exe
    For example: C:\Program Files\ArcGIS\bin\ArcSOM.exe

    Click OK.

  9. Click Add Program to add an exception for ArcSOC.exe.
  10. Click 'Browse' and navigate to:
    <ArcGIS Install Directory>\bin\ArcSOC.exe
    For example: C:\Program Files\ArcGIS\bin\ArcSOC.exe

    Click OK.

  11. The ports and programs entered should now appear in the list of Programs and Services. Verify that check marks appear next to each component.
  12. Close Windows Firewall.



ArcIMS

1. XML declaration may appear only at the beginning of a document in ArcIMS 9.x when creating feature, metadata, or image services with Windows XP SP2 or SP3.

Workaround: Refer to ESRI Knowledge Base article 28313 for more information on this issue. -show me-

Description
When trying to create image, feature, or metadata services using the ArcIMS Service Administrator (esriadmin) on Windows XP Service Pack 2 (SP2), an error message is returned and the services are not created. The following error is returned:

"XML declaration may only appear at the beginning of the document"

This problem can occur when:

- ArcIMS 9.0, without Service Pack 2, is installed on Windows XP SP2.
- ArcIMS 9.0, with Service Pack 2, is installed on Windows XP SP2 and the servlet engine is Tomcat.
Cause
The arcims_jconnect.jar file that is being used by Service Administrator is not the most current version.
Workaround
This problem is resolved with an updated version of arcims_jconnect.jar that is installed with ArcIMS 9.0 Service Pack 2. Complete the following steps to verify the file is up to date:

If ArcIMS 9.0 Service Pack 2 has not been installed, install it. A link to ArcIMS 9.0 Service Pack 2 is provided by way of the Related Information section below.

If the problem still occurs and ArcIMS 9.0 Service Pack 2 has been installed on a machine that is using Tomcat as a servlet engine, perform the following:

1. Stop the Tomcat service.
2. Navigate to <Tomcat Install Directory>\webapps and delete the \esriadmin folder.
3. Start the Tomcat service.

 The \esriadmin folder is re-created with the most current files.





2. Legend frames do not refresh in ArcIMS 9.x projects with Windows XP SP2 or SP3.

Workaround: Refer to the ESRI Knowledge Base article 28315 for more information on this issue. -show me-

Description
The legend feature works on first load of jspviewer with the SantaClara service; however, when loading a different service and clicking on the legend tool, the following javascript error occurs:

"Access is denied"

This problem can occur when:

- ArcIMS 9.0, without Service Pack 2, is installed on Windows XP Service Pack 2 (SP2).
- ArcIMS 9.0, with Service Pack 2, is installed on Windows XP SP2 and the servlet engine is Tomcat.
Cause
The arcims_jconnect.jar file that is being used by the jspviewer sample is not the most current version.
Workaround
This problem is resolved with an updated version of arcims_jconnect.jar that is installed with ArcIMS 9.0 Service Pack 2. Complete the following steps to verify the file is up-to-date.

If ArcIMS 9.0 Service Pack 2 has not been installed, install it. A link to ArcIMS 9.0 Service Pack 2, can be found in the Related Information section below.

Download ArcIMS Service Pack 2 by navigating to ESRI Online Support > Downloads > Patches & Service Packs > ArcIMS by way of the Related Information section below.

If the problem still occurs and ArcIMS Service Pack 2 has been installed on a machine that is using Tomcat as a servlet engine, perform the following:

1. Stop the Tomcat service.
2. Navigate to <Tomcat Install Directory>\webapps and delete the \jspviewer folder.
3. Start the Tomcat service.

 The \jspviewer folder is re-created with the most current files.




3. When installing Windows XP SP2 or SP3, the install enables a firewall called Windows Firewall. The default settings in the firewall cause ArcIMS 9.x to block all incoming connections. To correct this, add exceptions in the Windows Firewall. For instructions on how to do this, refer to -

How-To: Configure Windows XP SP2 or SP3 Firewall to work with ArcIMS, ESRI Knowledge Base article 27854. -show me-

Summary
Instructions provided describe how to configure Windows XP SP2 Firewall to work with ArcIMS. Windows XP Service Pack 2 must be installed to complete the procedure below, which outlines the steps required to configure Windows Firewall for ArcIMS.
Procedure
When upgrading Windows XP with Service Pack 2, a firewall titled 'Windows Firewall' is installed and enabled. The default settings for the firewall cause Windows XP to block all incoming connections for ArcIMS. The workaround below creates exceptions for the ports used by the Web server, Servlet Engine and ArcIMS in the Windows Firewall settings.

  1. Navigate to Windows Firewall.

    Start > Settings > Control Panel > Windows Firewall

     The firewall is 'On' by default, the 'Recommended' setting.

  2. Click on the Exceptions tab.
  3. Click 'Add Port'.
  4. Add the following information:

    Name: Web Port (http)
    Port Number: 80
    Type: TCP

      If this is a single machine ArcIMS installation where all components such as, Web server and Servlet Engine are on the same physical machine, skip to step 7.

  5. If ArcIMS is deployed in a distributed or multiple machine configuration, the appropriate ports need to be opened by repeating steps 3 and 4 above, as well as the following additional steps:

    Ports and settings for ArcIMS:

    Name: ArcIMS AppServer Connector Port
    Port Number: 5300
    Type: TCP

    Name: ArcIMS AppServer Register Port
    Port Number: 5353
    Type: TCP

    Name: Monitor Listener Port
    Port Number: 5050
    Type: TCP

    Name: Tasker Listener Port
    Port Number: 5060
    Type: TCP
  6. If ArcIMS is deployed in a distributed or multiple machine configuration, and the Spatial Server is installed on a Windows XP SP2 machine, perform the following steps:

    A. Click 'Add Program'.
    B. Click 'Browse' and navigate to:
    <ArcIMS Directory>\Server\bin\aimsserver.exe
    For example: C:\Program Files\ArcGIS\ArcIMS\Server\bin\aimsserver.exe
    C. Click 'OK'.
    D. Verify that the exception for the Monitor Listener port has been created as shown in step 5 above.
  7. The ports and programs entered should appear in the list of Programs and Services. Verify that check marks appear next to each component.
  8. Close Windows Firewall.

Created: 2/16/2005
Last Modified: 10/8/2008

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