PROBLEMA

Las solicitudes a ArcGIS Server mediante un Web Adaptor instalado en Oracle WebLogic tardan 20 segundos o más en completarse

Last Published: March 12, 2021

Descripción

Cuando se accede a los recursos de ArcGIS Server a través de un Web Adaptor que se ha configurado en un servidor web de Oracle WebLogic, las solicitudes tardan 20 segundos o más y, en ocasiones, no se completan.

Causa

Un problema en el servidor web de WebLogic provoca que las solicitudes en caché dejen de responder.

Solución o solución alternativa

La solución sugerida por Oracle para este problema es cambiar la implementación de SSL utilizada internamente en WebLogic. En la mayoría de los casos, esto solucionará el problema, independientemente de si las solicitudes se están realizando a través de HTTPS.

Advertencia: Esri no ofrece soporte completo para los siguientes pasos, ya que técnicamente el cambio se está realizando en el servidor de Oracle WebLogic.
  1. Ir a la Consola de administración para el servidor WebLogic
  2. Navegue a la pestaña Inicio > Resumen de servidores > [Nombre de servidor] > Configuración, Arranque del servidor, donde [Nombre de servidor] es el nombre del servidor en el que está instalado WebLogic.
  3. Agregue lo siguiente a la sección Argumentos:
Código: -DUseSunHttpHandler=true
  1. Reinicie el servidor de WebLogic.

Id. de artículo:000012799

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Descubrir más sobre este tema